FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma 7 upgrade script failing


(Marbled) #81

Hi!

If you try removing libcurl-devel, does it want to remove anything else or just this package?

If it only wants to remove that package, say yes, if it wants to remove anything else, say no and post the output here…

If you successfully removed it, reboot to see if it goes further and keep us posted…

Good luck and have a nice day!

Nick


(ADTopkek) #82

That worked! Now it is progressing further. Thanks!

Now its downloading an empty core module. Strange… Maybe I need the full url to the core.


(Andrew Nagy) #83

What system are you running this on. Doesn’t seem like the freepbx distro.


(ADTopkek) #84

Its an upgrade from the FreePBX 13 distro. Testing the upgrade on a clone of our main system. I also noticed apache is down, perhaps thats causing an issue.


(Marbled) #85

Hi!

Is this a VM and do you still have network connectivity when this runs?

Also, but I doubt that is still a problem, do you have any DAHDI hardware?

Some early testers (I was one of them) had problems which seemed to be related to running a VM or having DAHDI hardware…

Good luck and have a nice day!

Nick

Ps: you took care of any conflict of IPs?


(Tony Lewis) #86

This does not look like a Distro system. Those package conflicts you have are not packages we had in our repos. Something is not adding up here on this.


(Marbled) #87

Hi Tony!

Maybe he added some…

(This could lead to some uninteresting results while doing the upgrade I think…)

@adtopkek, can you do a

yum repolist

at the command line and post the results here?

Have a nice day!

Nick


(Serggio) #88

Hi all.
I reported an issue here:
https://issues.freepbx.org/browse/FREEPBX-15498

It was marked as Resolved and Closed. I waited two weeks. Today tried again udate script (instruction) and faced with same issue. I really dont understand what should I do to fix it.
Maybe somebody more experienced advise me, where I made mistake? Or I should wait more time?


(ADTopkek) #89

Hum… At one point in time we were running Freepbx 13 on Centos. We switched to a Sangoma recommended host and started using the Freepbx Distro at that point. I think the backup/restore was used to migrate. I wonder if we copied over some things we didn’t want.

Upgraded Server:

Non-upgraded server:


(Tony Lewis) #90

backup and restore would not install RPMs. The reason I say it did not look like a Distro install is one of the RPMs above you are having a conflict with is not from us. Would appear you installed some RPMs at one point from another source.


(ADTopkek) #91

Ok I had the Freepbx 13 Distro reinstalled. I fully updated to asterisk 13 then ran backup/restore. Restored extensions_custom.conf, voicemail.conf, the /var directories, and the freepbx config db. Everything seemed to be running fine with a quick check of a few basic features. Followed the upgrade guide and only had one issue till the screenshot.

That issue was the script didn’t wait long enough for my server to connect to the internet and it timed out. I had to find the log that said to run: /usr/sbin/post_upgrade

Then it installed everything smoothly this time till it stopped at this same spot:

I wonder if its trying the correct repo. Everything still looks like V13


(Andrew Nagy) #92

You are still on freepbx 13


(ADTopkek) #93

I thought the core module update part was what switched freepbx to version 14. Or does it look like some step is being skipped? All I’ve ran so far is /usr/sbin/post_upgrade

FW Console - FreePBX Utility 14.0.1.4


(Matthew B) #94

E1000 or NE1000 as shown in my screen capture?


(Liquid Bunker) #95

Hey guys,

i’ve tryed to update our Sangoma 7 too. The script installed everything smoothly till it stopped at this same spot: ###Running Yum Upgrade###

At this point I get an endless loop.

Does somebody has any idea?


(Marbled) #96

Hi!

Yes. Create a ticket and upload the two files asked for in the troubleshooting section of the wiki page you followed to upgrade.

There’s most likely a broken dependency somewhere but it doesn’t show in your screen capture…

Once that is done, please post your ticket number here if possible…

Good luck and have a nice day!

Nick


(Liquid Bunker) #97

Thank you Marbled. A other User have the same problem as me

https://issues.freepbx.org/browse/FREEPBX-15608


(Marbled) #98

Hi!

Having the same symptoms doesn’t mean you have the same problem… That’s why unless you already know what the problem was and fixed it you should post your logs…

In his case the fix is

yum remove gnome-disk-utility-libs

at the command line.

That infinite loop is always or almost always a sign of broken dependencies, this is one in that person’s logs…

It was in mine too but not the only one which is which is why saying you have the same problem is not very useful as far as finding a fix for your problem.

If you look at the early messages in this thread (which I opened by the way) you will see I had the same looping problems but the fix was not exactly the same (and was one of many since I ran the earliest publicly available distro upgrade “script”.

You can try the command I suggested above to see if it fixes your problem… If you are lucky it will, if you are not we will need actual logs (or at least the part where it suggests the “–skip-broken” switch if there is one…).

Good luck and have a nice day!

Nick


(Tony Lewis) #99

We never included gnome as a installed packge. This must be something you had installed yourself manually.


(Marbled) #100

Hi Tony!

I too had that package before I upgraded over 2 months ago…

My guess is that it was pulled as a dependency of something else that was either installed as part of an update or something we manually installed…

On the test/home FreePBX distro system I had this on the only packages I remember installing were for media conversion and Bluetooth (when I played with chan_mobile).

(This is why I was so much looking forward to the updated kernel which addressed Blueborne… :sweat:)

As for @liquidbunker, looks like he has multiple problems :wink: because he posted in FREEPBX-15623 that he had the same problem as well (and this is a much different problem with missing dependencies and improperly updated commercial packages).

It looks like in his case her/his problem might be caused by a python dependency problem which I am not sure how (s)he should fix and which I can’t research right now…

Like I said earlier, same symptom(s), different problem(s)…

Have a nice day!

Nick