FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma 7 upgrade script failing


(Marbled) #1

Hi,

It fails on my box…

It’s unable to resolve some URLs after a reboot but it looks like the main problem is that my network card no longer has an IP.

Anyone has an idea?

I guess I will soon see how good my backups are… It’s the box I am running at home and it has to be up before I go to sleep…

Nick


FreePBX 13 -> 14 Upgrade Script kills DAHDI
(Andrew Nagy) #2

Your network card is probably not supported in CentOS 7


(Marbled) #3

Hi,

I seriously doubt it since, IIRC, it’s something pretty common but let me go check…

Nick


(Andrew Nagy) #4

For troubleshooting sakes you should try to see why you aren’t getting an IP address.

We have extensively tested this with our QA team not that there won’t be issues…


(Rob Thomas) #5
  1. Does it have link status?

[root@docker tests]# ethtool eth0 Settings for eth0: Supported ports: [ TP ] Supported link modes: 1000baseT/Full 10000baseT/Full Supported pause frame use: No Supports auto-negotiation: No Advertised link modes: Not reported Advertised pause frame use: No Advertised auto-negotiation: No Speed: 10000Mb/s Duplex: Full Port: Twisted Pair PHYAD: 0 Transceiver: internal Auto-negotiation: off MDI-X: Unknown Supports Wake-on: uag Wake-on: d Link detected: yes [root@docker tests]#

2 . Can you see traffic? (Run ‘tcpdump -i eth0 -s0 -nn -vv’)

3 . Is the interface enabled onboot? (Have you tried ‘ifup eth0’?)


(Bryan Walters) #6

@Marbled, if possible can you give us the hardware specs of the system that this was run on?


(Marbled) #7

Hi Rob!

Yes…

Yes…

No…

No, I just did and because of your great suggestion I found the problem!

The subnet mask was wrong…

This is a box I initiallly setted up on the same network segment as my other PCs and servers but that I moved to, essentially, a DMZ…

It still had the the subnet mask of the main network segment, not the one it should have…

Surprisingly that one digit difference between the right subnet mask and the wrong one didn’t cause any problem with the old Centos 6.x but failed miserably with Sangoma 7…

I fixed the problem and restarted the system and it seemed to work nice for a while but now it seems to be continuously showing dependencies problems between Sangoma 7 and el6… It seems to show the same errors over and over…

I will try to get a picture and post it here (if I don’t lose electricity in the mean time, we have pretty bad weather here…)…

Thank you and have a nice day!

Nick


(Marbled) #8


(Marbled) #9

There’s more than a page of this and it loops over and over again after a few seconds…

Is there any way to get this working again?

Thank you and have a nice day!

Nick


(Rob Thomas) #10

Any rpms with ‘el6’ in the name should be gone. Can you push Alt-F2 and switch to a console and remove them manually?


(Marbled) #11

Hi Rob!

It complains that yum is already running with another process id…

I had to stop the upgrade to remove some packages but it looks like it might take a loooong time to remove everything conflicting…

I tried to ask it to remove everything el6 and it looks like the Sangoma 7 packages have some dependencies on them…

I just rebooted the box to see if thing are better this time but can I restart the script manually without needing to reboot?

Thank you and have a nice day!

Nick


(Andrew Nagy) #12

This ticket appears to be the same as this thread: https://issues.freepbx.org/browse/FREEPBX-15489


(Marbled) #13

Hi Andrew!

Yes, it sure does…

My network card does work now (after fixing the subnet mask) but name resolution is out…

I guess it might be a library problem or something similar…

I tried moving different DNSes entries in and out (the loopback “cache”, a Google one and the one provided by my router) of the way and allowing any traffic from the PBX to the Internet and nothing worked…

I tried manually running “yum update” and it suggested to add the switch to skip the broken dependencies but that did not give any result because it’s unable to resolve the package locations…

The only thing I can see that could be “non-standard” about this FreePBX distro box is the fact that I added packages which were not there by default (but no additional repos I believe). IIRC I had added packages to do git/svn checkouts, handle Bluetooth (for chan_mobile) and maybe a few packages to compile things to handle additional audio formats (that you could not install by default for possible liability reasons). It might be a good idea to check if the person who created the ticket is in the same situation…

These are the only things I could think of not every distro system might have had…

Except for that, everything was pretty standard…

I am calling it quits for tonight…

If you have any suggestions I can try tomorrow when I get back from work (this is my home test server) I will do then as soon as I can…

If it turns out nothing can be done then let’s hope my backup actually works…

Thank you and have a nice day!

Nick


(Marbled) #14

Hi Andrew and Rob!

I have created my own ticket (as asked in the troubleshooting section of the upgrade page), it’s

https://issues.freepbx.org/browse/FREEPBX-15491

I have attached both the sngupdate and post_sngupdate files to it.

Thank you and have a nice day!

Nick


#15

I had exactly the same problem as marbled - it was stuck in a reboot loop running yum -y upgrade. I killed the script by pressing CTRL + C rapidly and worked out it was bombing out on nodejs-docs. I manually ran “yum upgrade --exclude=nodejs-docs” and it appears to be progressing through the upgrade now. Will confirm soon.


#16

That didn’t work. I had to “yum remove nodejs-docs” and now it’s completing.


(Marbled) #17

Hi and thank you for your input!

Did it complete successfully?

I see the same problem in the logs I put in the ticket, ie

Error: nodejs-docs conflicts with 2:nodejs-8.1.4-2.14.x86_64
Error: Package: 2:nodejs-devel-8.1.4-2.14.x86_64 (sng-pkgs)
           Requires: nodejs(x86-64) = 8.1.4-2.14
           Removing: 2:nodejs-6.9.5-1.7.x86_64 (installed)
               nodejs(x86-64) = 2:6.9.5-1.7
           Updated By: 2:nodejs-8.1.4-2.14.x86_64 (sng-pkgs)
               nodejs(x86-64) = 2:8.1.4-2.14
           Available: 1:nodejs-6.10.3-1.el7.x86_64 (sng-epel)
               nodejs(x86-64) = 1:6.10.3-1.el7
           Available: 2:nodejs-6.8.0-1.6.x86_64 (sng-pkgs)
               nodejs(x86-64) = 2:6.8.0-1.6
           Available: 2:nodejs-8.0.0-2.12.x86_64 (sng-pkgs)
               nodejs(x86-64) = 2:8.0.0-2.12
Error: Package: gnome-disk-utility-libs-2.30.1-2.el6.x86_64 (@base/6)
           Requires: udisks >= 1.0.0
           Removing: udisks-1.0.1-7.el6_5.x86_64 (@base/6)
               udisks = 1.0.1-7.el6_5
           Obsoleted By: udisks2-2.1.2-6.el7.x86_64 (sng-base)
               Not found
 You could try using --skip-broken to work around the problem

I tried running yum update with --skip-broken and it was trying to download additional packages and it was failing because name resolution appears to be broken…

Thank you and have a nice day!

Nick


How to Upgrade FreePBX Distro 13 to 14
(Serggio) #18

Server stucked on:
Error running fwconsole ma downloadinstall framework - Retrying. Output was: /usr/sbin/post_upgrade:line 12:fwconsole: command not found.
Message repeating infinitely.


(Bryan Walters) #19

@Marbled, I’ve responded to your ticket, yet based on the comment above are you I’m confused if you are past the DNS resolution errors in the original ticket or not?

@ar_gen_tum, Can you please open a ticket with the log files from the troubleshooting section of the ticket?


(Marbled) #20

Hi Bryan!

No…

Sorry, from time to time it most likely shows that English is not my native language…

What I wanted to say was

  • Was the problem fixed for her/him after he removed the package? I would try it but I won’t be able to for at least 6 more hours (my test system is at home…).
  • I see in the logs that I provided in the ticket that I seemed to have the same problem that he has (and one more with gnome-disk…)
  • I tried to run yum manually, ie not from the upgrade script, with the “–skip-broken” switch since this is what yum was suggesting me to do. It didn’t work as yum was apparently trying to download additional packages and name resolution doesn’t work on my system right now (and the network card is up).

I know that the outbound DNS traffic (port 53 UDP and TCP) is allowed by my firewall (and I even relaxed my rules to even more than they were) so I know it’s not a firewalling problem.

If I had to guess I would think it’s a problem with the wrong version of libresolv being used or something like that as everything else seems OK confguration-wise…

I replied to your question on the ticket, I use

127.0.0.1
8.8.8.8
172.16.2.1

First one is the one you (FreePBX devs) suggest putting first IIIRC, I believe it’s a DNS cache…
Second one is one of Google’s DNSes…
Third one is a DNS forwarder provided by my firewall… (pfSense)

Normally 172.16.2.1 would be before Google’s DNS but I had been testing something…

I tried to comment out 127.0.0.1 just in case there might be a problem with it and it made no difference (anyway it should have fallen back by itself to the others by itself but I just wanted to be it was not to blame…

Thank you and have a nice day!

Nick