S705 Phone Locks Up when Checking for Updates

FreePBX hosted
Asterisk 13.19.1
S705 Firmware
Exp100 module
I am having an issue with an S705 (w/1 exp100) freezing when the phone auto checks for updates or when I use EndPoint Manager to push an update to the phone. I have experienced this with 2 different S705 phones. I have also replaced the template file with one that has been working on an S500 phone. Have tried resetting the phone a number of times. There are other Sangoma and other brands of phones on the same network using the same POE switch all working flawlessly. Only having an issue with the S705.

Would appreciate suggestions on how to best troubleshoot this. The only time the phone successfully pulls updates is when it checks during the startup process.
Appreciate any help you might offer.

In reference to topics discussed here:

I have the S705 set to update over HTTPS.

Does it happen over http as well?

Thank you for the question. Just tested. I can confirm that over HTTP, it does work. I can push an update from Endpoint Manager and successfully update the phone.

Tried again to switch back to HTTPS, it locked up as soon as attemping to use this secure protocol.

Does anyone have an idea on how to fix this? I have about 5 other phones all successfully receiving updates over HTTPS. Not sure why only the S705 is having issues? I don’t want to use an insecure protocol but until this is resolved, I can have the S705 connect over VPN and Provision over HTTP.

I would report this as a bug, might be there’s already a report.


1 Like

Please open a bug report on this. The s705 is a whole different beast than all the other phones. It has a ARM CPU which all of our phones as we redesign are moving to. It was the first one and the new s305 also has the ARM CPU. This is why we can do things like OPUS codec and lots of other things coming up we could not do with the existing models.

Why am I sharing this. It’s because they use a different firmware stack and OS as you can imagine then the original phones so things that work on the other models may not work here when you find a bug.

1 Like

Thank you to Itzik and Tony for the feedback!
I have submitted a ticket (TELE-789). Look forward to helping any way I can to create a resolution for this.

1 Like

Had the same issue. The answer was changing the Phone provisioning and Phone Apps to HTTP. That seemed to help. They did just release a firmware update (1.48 in Endpoint manager) that states in the release notes that the firmware fixes S705 + EXP100 lockup issue. Recommend installing the latest firmware if you haven’t already.

So far, I’ve left HTTPS off, but turning it on a few phones just to see if it does lockup again.

Thanks for the suggestion, Chris. I have been running 1.48 ( for S705) for several days now. I saw that note too about fixing the lockup issue with expansion. Unfortunately, that was not the bug fix that was needed as I am still experiencing the lockup issue when the phone tries to get an updated config over HTTPS. Now that I have had some time to play with it more, pulling config settings over HTTP does seem to be the much more stable option.
If you have the chance, I would be interested to see if you are also still experiencing the lockup issue getting config settings over HTTPS. (Just for clarity, this is only impacting the S705 phone that I have. I also have an S500 and S300 both working flawlessly pulling configs over HTTPS. Love the Sangoma phones when they work right!)

I just tried it today (6/20) and with a s705 and an EXP100, if I set the config for HTTPS, it will lockup at Checking firmware. If I change it back to HTTP, it works without issue. So even with the latest firmware, the S705 and the EXP100 will not get past checking firmware using HTTPS.

Sorry for your problems but glad to hear I’m not alone on this. The solution for me was to set the 705 to connect over VPN and HTTP. It is my understanding that all communications from the phone should be over VPN when this is enabled therefore providing a layer of security while still getting it to function.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.