S500 phones show "Login ..." on two first line keys

FreePBX 15.0.23 / Current Asterisk Version: 16.24.1 / with latest updates

As in the subject line, I have two S500 phones provisioned as remote extensions with VPN activated which are displaying “Login …” on the first two line keys.

Firmware(IMG): 17:06:00)
Firmware(BOOT): 10:19:00)
Firmware(ROM): 17:06:00)

When either the Line 1 or Line 2 key is pressed, the message is “WARNING: Failed to load xml file !”

Otherwise both phones are working as expected.

There is an earlier post from Oct. 2018 which may be similar to this issue “Sangoma phones randomly displaying Login Int / Login Ext” but the post does not appear to have provided a fix.

Can someone point me to a fix? Thanks.

Hi @sgseidel
I think below wiki page will be point you to fix your Login/Logout with Zero Touch Provisioning.


@shahin Thanks for your reply. FYI, I did use Zero Touch Provisioning to set up both S500s a year or so ago, but I will use ZTP and follow the wiki carefully once again to set up these phones.

The first thing I notice is that a couple of my ports are slightly different than the wiki (see the attached screen shot).

As you can see, the port details are different:
Firewall Zone(s) for Secure HTTPS Provisioning is “Trusted only”, for RESTfull Apps is “Internal”, and for Secure RESTfull Apps is “Trusted only”. In the wiki, the Firewall Zone(s) are all “Internal, Other”

Also my Secure RESTfull Apps port is 5443, while in the wiki it is 3443 (I doubt this is an issue, but I’ll note it anyway).

Could this be causing the original issue?

Now, after following the ZTP wiki as carefully as I could, the original issue still exists. That is, the first two line keys say “Login …”. By the way, when these two phones were first provisioned with ZTP this issue did not occur.

Hi @sgseidel
No idea for ZTP phone, Could be different Software or Firmware you have on it.
The ZTP phone chassis looks same but not same Firmware have as S Series phones.

Good luck i wish you…


Shahin N.

@shahin No, you misunderstand. ZTP=Zero Touch Provisioning. ZTP is an acronym, shorthand for “zero touch provisioning” and has nothing to do with any phone chassis that I’m aware of.

These are regular Sangoma S500 phones, sold and distributed by Sangoma, and I carefully followed the instructions using Zero Touch Provisioning provided in the Wiki. As I explained above, this did not fix the issue.

Sorry me :slight_smile:
for ZeroTouch Provisioning below thinks.
1- Sangoma Portal ZTP informations ( Server IP and Port number )
2- FreePBX allowed ZTP Ports ( Port management HTTP or HTTPS ports must allowed )

3- FreePBX Firewall → Service → Allow HTTP OR HTTPS ( up to your setting )
3A- If your PBX internal LAN ip then allow ( Port Forward HTTP or HTTPS ZTP Ports to your PBX IP )

4- End Point Manager → Template → Global Setting ( Check Internal && External Address information ) must be fill up + check Ports informations is well.
4A- EPM → Sangoma → S Phones → New Template → Provisioning Protocol ( HTTP or HTTPS ) → Provisioning Address ( External) → Models Tab → S 500 → XML-API Login / Rest-Login → Save

5- EPM → Extension Mapping → Select your Login/Logout Phone and change to ^^ created template.
6- Admin → Rest-API → Server Status :Enable
7- Admin → Phone Aps → EPM → User Manager authentication : YES

You can check your Template ( Login Logout ) running ( calling ) template from web browser


make a factory reset of the your Phone. and check on FreePBX Logs

tail -f /var/log/httpd/access_log | grep “Sangoma”

After factory reset your phone will be git your PBX ^^ if everything correct up and ZeroTouch Provisioning Wiki…

And check PM2 you have to see running phoneaps and resapps modules.

fwconsole pm2 --list

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.