RPM command errored, Delete /dev/shm/yumwrapper/* and try again. Exit code 1 - see FreePBX log for more info

Out of the blue, I got this error when I went to check for modules update. I have no idea how to begin troubleshooting is type of errors. Can anyone help?

BTW, I’ve checked for the file /dev/shm/yumwrapper/*. No such file or directory is found on the system…And where is the FreePBX log?

My 2nd server now caught the same error.
There was an un-applied (red button) on the app when I logged in. I clicked it…and now…it is showing the same error as the 1st server. What ever was in the forced upgrade (or update) it must have caused the error.

Hi Kyiu,

I encountered the same thing after automatic module upgrades. I had two files located in: /dev/shm/yumwrapper/ I deleted those two files and things were happy again.

I don’t mean to offend, but I don’t know your level of Linux skill. Maybe this will help:
After logging into the server’s console (command line) enter the following two commands:

cd /dev/shm/yumwrapper/

(This will “change directory” into the directory noted in the error message.)


(That’s a lowercase letter L and this command will list any files in this directory.)

If there are any files listed, you need to delete them using the rm (remove) command. You could enter:

rm *

to remove ALL files in that directory. You should be prompted to confirm the removal. After removing the files, your module page should work again, at least mine did.

Apologies if you already knew this.

1 Like

Thanks for replying. No offence. But my Linux skill is up to snuff. I did exactly the command on my 3rd server. I couldn’t find the directory as you’ve suggested. I’ll again. May be my typo.

The issue is fixed.
The directory didn’t exist on my 3rd server because the 3rd server didn’t have the issue. Thank you very much for your help :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.