Route password not working with CustomContext


Using FreePBX with Asterisk 13, and the Custom Contexts module. I have CustomContexts set so that some phones have restricted access to outside lines, and allow only outbound routes that require passwords.

The PBX does ask for the password, and it shows the correct password in the /var/log/asterisk/full log, but when the user enters it on the phone, it says it is incorrect.

I’ve tried removing the password, and it does go thru, so I know I’m modifying the correct route entry. But even if I make it a single digit, I can’t seem to get it to work. Is it due to the context being different? How can I solve this?


Update: The customContext seems not to make a difference. I even tried adding a password to a route used by everyone, and from a regular phone set as “From-Internal”, it still says I have an incorrect password.

Another update:

I just did a fresh new install on another drive, 100% stock, no extra modules or anything. Set up one extension and route, and set a password for that outbound route. Does NOT work!

I’ve done a bunch of searching, but can’t find anyone discussing a bug like this. Is it perhaps a new bug?


Resolved: apparently my ATA adapter (Linksys PAP-2T) was sending double digits to Asterisk… Sigh, and what a waste of time! Had to change DTMF mode to AUTO.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.