Restore from 13 to 15 not working. Hangs at 99.97% on upload

I did a fresh install of Freepbx 15 and updated all the modules. I created a backup of my Freepbx 13 and when I try to upload it in backup and restore, it hangs at 99.97% and never goes past that. I have tried multiple backups with the same results. Any help would be appreciated.

Do it from the command line. I’ve never successfully been able to upload a true backup file, from an active system, using the GUI.

Use scp, or WinSCP and load the file onto your new system that way.

Then use the command line to restore the backup.
Assuming you uploaded the backup to /var/lib/asterisk

fwconsole chown
fwconsole backup --restore /var/lib/asterisk/20200405-000001-1586059201-942371839.tgz

This method doesn’t work. At startup, an error appears:

[[email protected] ~]# fwconsole chown
Taking too long? Customize the chown command, See
Установка прав…
Setting base permissions…Завершено
Setting specific permissions…
_ 55006 [============================]_
Finished setting permissions

[[email protected] ~]# fwconsole backup --restore /var/lib/asterisk/elastixbackup-20201208123201-l6.tar
Transaction ID is: fb907cd9-66cb-47b7-b0a1-7d8accc3a995
Determining backup file type…type is legacy
Legacy CDR Restore Option: 0
Starting restore job with file: /var/lib/asterisk/elastixbackup-20201208123201-l6.tar
Extracting backup…
Parsing out SQL tables. This may take a moment depending on backup size.
Found 0 database files in the backup.
Restore completed successfully

For example, I posted a full backup archive without recording conversations and voice mail

The backup format appears to be wrong. I don’t know how that backup was made, but it was not done using the FreePBX backup module.

Sorry I was wrong with the topic :expressionless:

Thanks for the help. Performed another backup on the old system and was able to restore from it. The problem I am facing now after the restore to the new system is when dialing an extension, it goes directly to voicemail. The extension shows that it is registered. Also, when dialing on the main number, the IVR does not play and you get the error invalid response. If I go ahead and press a number it does transfer to that extension but goes directly to voicemail.

Try running

fwconsole util resetastdb
fwconsole r

I tried running this but did not help. Phones still show they are registered and can call out but goes straight to voicemail when calling in.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.