Remote extensions unable to send audio


I am having trouble with my remote extensions on my FreePBX Phone server. When I make a call to or from a remote extension, I am unable to hear any audio. I have forwarded the necessary ports (UDP port 5060 for SIP signaling and UDP ports 10000-20000 for RTP Media) on my router and firewall, but the problem persists.

This is almost always a nat issue.

Is the PBX behind double NAT?

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change them, after Submit and Apply Config you must restart Asterisk.

If that’s not your issue, at the Asterisk command prompt type
pjsip set logger on
sip set debug on
according to extension type. Make a failing call, paste the Asterisk log for the call at and post the link here. If you are too new to post links, just post the last 8 characters of the URL.


Thanks for the suggestion here’s what happened,

[[email protected] ~]# pjsip set logger on
-bash: pjsip: command not found
[[email protected] ~]# sip set debug on
-bash: sip: command not found

my router has an Inbuilt firewall, I am also using the FreePBX Firewall

These are Asterisk commands, not shell commands. At a root shell prompt, type
asterisk -r
and then issue the logger/debug commands.

Make/model? VoIP-related settings? Does it get a public IP address on its WAN interface? If not, is modem configured as a gateway?

asterisk -rvvv please so it contains the asterisk logs as well.

Okay I got the logs working, how do I pause it
and my router is a ARRIS TG2492LG-85 Router by Virgin Media

<— Received SIP request (485 bytes) from UDP: —>

ACK [sip:[email protected](https://);user=phone SIP/2.0

Via: SIP/2.0/UDP;branch=z9hG4bK-524287-1—4e8daaddc563df39;rport

Max-Forwards: 70

To: [sip:[email protected];user=phone;tag=z9hG4bK-524287-1—4e8daaddc563df39

From: sip:[email protected]:5060;tag=db3125eb

Call-ID: 203875_rel190YWM5N2NmZjU2YzIyNjM2MGMyMTY4ZGQwYTE2MmI2MjI

CSeq: 1 ACK

Content-Length: 0

This is a single response.

Please reproduce the issue and post the logs via

here you go.

This is literally a copy paste of the above SIP response… Please reproduce the issue and share a FULL call trace.

My bad, here you go

Your paste is private.

I’m am back

URL is still not accessible. Please paste another.

It appears that extension 209, though physically connected through H3G (Three) mobile data, is using a VPN from Securax with the server in Bulgaria. Though I can’t explain it completely, I suspect that the H3G address presented in the SDP on line 1174 of the log is somehow confusing Asterisk.

Please test with the VPN disabled. If that works ok, if it’s possible (and acceptable) to bypass the VPN for Zoiper, that would be simplest. Otherwise, we can look at Zoiper and/or Asterisk settings that may be a workaround.

If it still fails with the VPN off, please paste another log, with data taken from the Asterisk log (/var/log/asterisk/full), rather than the console output.