Reload failed because retrieve_conf encountered an error: 255

I upgrade to FreePBX Distro 6.12.65-31 and when I hit Apply Config I get an error ,

Reload failed because retrieve_conf encountered an error: 255

exit: 255
Unable to continue. SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘asterisk.freepbx_users’ doesn’t exist in /var/www/html/admin/modules/contactmanager/Contactmanager.class.php on line 604

I appreciate any info.

you need to reinstall usermanager

Just to confirm the steps of reinstalling usermanager.
Under Module administration, → User management, I click on uninstall then install.

uninstall and reinstall

you can also run

fwconsole ma install userman

Thanks After usermanager, got the same error on Contact manager and Bria so I also reinstall contact manager and bria. The apply config is fixed.

Now on the system status, it say I have 27 to update.

I purchase SysAdminPro before I upgrade to 13. I don’t see any update available.

I also notice it say current version is 6.12.65-31. Should that say 6.13.x.x.
If I have to do fwconsole ma install, on all the 27 modules, how do I get the module name like “userman” for user manager, etc.



fwconsole ma upgradeall

To move to the 10.x track from the 6.12 track you have to do it manually. Sysadmin won’t jump tracks so that it doesn’t break systems.

I did fwconsole ma upgradeall and got this error message

How did you update this system to FreePBX 13?

for now: fwconsole ma uninstall backup

then: fwconsole ma upgradeall

I did an update using the first option under admin “Upgrade 12 to 13”, It does system check and it passed. I didn’t watch the whole process but the last line was successful.

After I remove the backup all other modules updated successfully. The I click Apply Config and everything seem to be fine. Backup is still uninstall

Currently PBX Firmware: 6.12.65-31 PBX Service Pack:
I guess my next step is to apply 10.13.66.-
chmod +x

Once this is apply then I can continue with SysAdminPro to do the update via web

Will wait for your confirmation before I proceed. Should I install backup before upgrading to 10.13.66?

you can upgrade backup now: fwconsole ma install backup && fwconsole ma upgrade backup

I installed and upgrade the backup as per your instruction. It was successful. Before upgrading to, I decided to create a full backup job and save it successfully. When I run it I get the following error message.

sh:/var/lib/asterick/bin/backup.php: permission denied.
Should I do chmod 755 /var/lib/asterisk/bin/ backup.php?

This command cleans up all the permissions:

fwconsole chown

Backup is now working. I run, so far is seems to continue running but i’m getting a few errors