Reload Error

Went to reload a module update, got this error, how to fix?

retrieve_conf failed, config cannot be applied (shows as critical error)

Error 255


1 Like

Run the below

fwconsole ma downloadinstall core --force
fwconsole chown
fwconsole reload

If it errors out, please post the full error

Retuned same error:

Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 255
Unable to continue. Call to undefined function FreePBX\modules\Core\Drivers\version_min() in /var/www/html/admin/modules/core/ on line 499
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, ‘Call to undefin…’, ‘/var/www/html/a…’, 499)
#1 [internal function]: Whoops\Run->handleShutdown()
#2 {main}

Hi @mike366,

Please update the framework to latest release.


Mod Edit #1 - FreePBX Core module ver. requires Framework module version or higher. As of the time of this writing this verison of framework is in edge. You can find your current versions with:

fwconsole ma list | egrep "core|framework"

You can update framework with:

fwconsole ma upgrade framework --edge

Mod Edit #2 - Framework is in stable repo now, you can fix with:

fwconsole ma upgrade framework

To do so, run

fwconsole ma upgrade framework

If it’s already up to date, try updating to edge version

fwconsole ma upgrade framework --edge

Try reloading again

fwconsole reload

That worked, not sure what the issue is in the non-edge version, I asume the error message is correct about missing a function.

Will I need to go back to the non-edge version?

No repos specified, using: [standard,commercial] from last GUI settings

framework is the same as the online version, unable to upgrade

Module framework version successfully installed
Updating Hooks…Done
Updating Hooks…Done
Resetting temporarily repository state

fwconsole reload
Reloading FreePBX
Successfully reloaded

No. As you can see here.

Ahhhh, right…thanks Itzik!

Worked for me thank you!

May I ask if releasing a multi-module update that requires a module in Edge was done in error? I should think that only stable modules should be used in releases for production systems.

I installed a new core and framework module and now I can’t access inbound routes, extensions, and many other applications. I get the red error message in the upper right. I ran the commands you designated and rebooted the server to no avail. All the functions of call routing seem to be working, but I can’t view any of the affected extensions or inbound routes. This seems like just a display issue with Freepbx. Any advise other than what you already recommended? See the

Seems like your message got cut short,

Anyway, I’d advise you to create a new topic, post the PBX and module(s) version you have.

In the meantime, you can quickly check if you have any disabled modules.

Sorry, newbie here. I was going to put a screenshot in, but saw I couldn’t. I’ll post a new topic with all the bits.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.