Register phone to FreePBX with AD credentials

Good day, I’ve a server with FreePBX. I’ve successfully configured it to make calls from softphones and IP phones.

Now I want to use AD users in FreePBX, so I assigned them an extension, and connected the AD to FreePBX, so I can see them there, however, I cannot manage to configure them on the phones.

I’ve tried to configure a softphone (MicroSIP, phonerlite, jitsi, … ) but no luck so far. It says wrong password but when managing the users I don’t see how to assign a password so I assume the password is the one in Active directory, which is the one being used and throwing the error.

Any idea of how to solve this? Thank you in advance!

AD integration is for UCP not pjsip/sip devices

Thanks for the quick reply. I’m trying with Zulu now.
I get the error “There is an error trying to reach the server”
Any way to debug it? Does zulu provide error logs?

On the other hand, UCP tells me invalid credentials.

the ad integration has nothing to do with sip registration itself , it simply marries a AD user to a PBX extension using the iPPhone attribute from AD ( I typically set this with ADSI edit )

Zulu is EOL , please look into Sangoma Phone ( desktop )

AD integration is used for the desktop softphone login

confirm your directory is connected and that you’ve set some filters to capture only the PBX users and groups you defined versus all AD users and all AD groups

standard LDAP is pretty straightforward and LDAPS works as well but use a trusted third party cert on the AD system if thats the route you want to go

I don’t seem to be able to login with Sangoma phone in Windows, I get the error:
This PBX is not supported, please contact your administrator.
I’ve tried non AD users and I get the same error.

At what point is the cert needed? Maybe that’s the issue?

are you specifying the port in the host field ? many forget to do so and receive that particular message, it should look like →

you should also confirm the AD auth is working for the user by logging into the user control panel … UCP uses the same credentials as desktop; if its not working for UCP your directory is not configured properly - confirm it with UCP then try the sangoma desktop phone

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.