FreePBX | Register | Issues | Wiki | Portal | Support

Reducing the MTU for clients connecting via ipsec VPN tunnels

configuration
Tags: #<Tag:0x00007f74a3d45f20>

(Mluckham) #1

FreePBX distro 10.13.66-16 installed on a virtual machine. Both clients that connect must use Cisco Anyconnect to have connectivity to the VM’s IP address.

We have Shoretel and Cisco CUCM servers similarly connected to the network, and I have had to reduce the MTU size of both of those to 1120 - so that large UDP packets emitted by the servers can reach the clients.

Logging in to the Asterisk server with putty and as root, I’ve been unable to change the MTU setting for eth0. The current setting is 1500.

ifconfig eth0 mtu 1120
SIOCSIFMTU: Invalid argument

(ifconfig eth0 mtu 1500 does not return an error)

Tried editing /etc/sysconfig/network-scripts/ifcfg-eth0 to add MTU=1200

ifdown eth0; ifup eth0
RTNETLINK answers: Invalid argument

I have read that Centos 6.6 has a bug setting MTU below a certain value.

Short of upgrading the operating system or reinstalling the FreePBX distro, can anyone help me get this MTU changed?


(system) closed #2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.