Recover Root Password on Sangoma Linux 3.10

I am trying to recover a root password that I lost due to a system crash on my password manager where I store all my PWs. I do have a console / iLO access to the server. I tried following the guide line provided in another thread : Home - IPComms

However in my case this latest version of the FreePBX software, I do not have an option to select the kernel. Upon hitting “e” I am left with this screen

How can I reset my root password on the newer platform of the FreePBX?

Solved the issue : here is the fix

once you hit ‘e’
Scroll until you see the line that starts with “linuxefi” then add the following after UTF-8 "rd.break enforcing=0 " (w/o quotes)

Once you get the prompt : enter “mount -o remount,rw /sysroot”
then enter “chroot /sysroot”
then “passwd”
(enter your new password)

Reboot and it should accept your new password.

having the same problem i try what you said but no luck any recomedations

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.