Re-parking a call

Version: FreePBX 12


I’m having an issue when trying to re-park a call. I can park it fine the first time, but the second time the call seems to return to the origin (the original parker).

I was able to find this post that seems to be relevant

I have added both of these settings under Settings–>Asterisk Sip Settings–>Chan SIP–>Other SIP Settings

Unfortunately, it doesn’t seem to help. Can someone point me in the right direction?

Thank you



I tried this on an Aastra 6869 and I have exactly the same issue. Can someone assist?

If this something that paid support would assist with if needed?


Seems to work fine from my testing.

I called an extension. Sent it to parking lot. Retrieved it. Rinse and Repeat 3x times.

Can you confirm exactly which way you sent it to the parking lot? *2XX?

It must be a setting somewhere otherwise to return the call to the original user rather than allowing the user to re-park.

How do I go about debugging this as it appears to be consistent? and as it happens on two phones it appears to be freepbx/asterisk related rather than phone related.

You have to repark the call manually. It wont repark itself automatically.

Hi Tony,

I do re-park it manually. I park it all times with *2XX (where XX is the slot).

Is there another way to park the call?


In the park module have you enabled the option that says repark?

In the parking module I have

“Re-Parking Capability:” set to both

Is this the item you reference?

Any further thoughts?

If I signed up for a support package is this the kind of issue I can get assistance with?

I have used freepbx at home for many years and am trying to complete this POC to get it into my company.

Yes this is something we can help you with over support. If it turns out to be a valid bug the support staff will give you two options:

  1. Use your support credit to pay for a fix
  2. Don’t use support credit but instead open a freepbx ticket and go through the normal ticket queues like everyone else (free)

In the end the support staff will probably still use about 10 minutes of time to diagnose if there is an issue or not. (It is not free when we have to login to your system and figure out and test)

Thanks Andrew. I have opened a ticket and offered my support credit. The tech was connected to the system today and I am awaiting a response on the issue. I’ll post back the response so it might help someone else with this issue.

This was a bug in Asterisk. A workaround has been applied in the latest Parking module (released today)

Thanks Tony!

1 Like

I was the tech that worked on it. Enjoy. :wink:

In that case - Thank you Andrew!. I was able to show my demo and get approval to move ahead, so it was worth the late night!

Parking is always weird so please feel free to let us know if you have any more issues. Either here (forums) or other means. Thanks