Queue autopause pausing members regardless of settings

Hello, we have a queue setup with the following settings:

Ring Strategy: Ring All
Static/Dynamics Members: (Empty), they will use FOP2 to log in/out dynamically.
Skip Busy Agent= Yes
Auto Pause = yes in all queues
Auto Pause on Busy = No
Auto Pause on unavailable= No

When a queue call comes in and an agent in already on a call, it will mark the Agent as Busy preventing the agent from receiving any new calls. Even after the Agent hangs up, it continues to remain paused until manually unpaused.

I thought with the skip busy agent option this would resolve the issue but somehow it still pauses the agent even though no calls went to the phone.

FreePBX 12.0.48
Asterisk 11.15

Any suggestions?

Thanks

Noticed this on verbose logging:

VERBOSE[12724][C-000044f6] app_queue.c: – Auto-Pausing Queue Member Local/[email protected]/n in all queues since they failed to answer on queue 5001.

Still having this issue even after upgrading all modules… anyone have any suggestions?

The solution in case anyone runs into the same issue.
I looked into the queues_additional.conf file and noticed ringinuse was being set to yes even though I had skipbusyagent=yes. I then noticed there was another option called ‘Yes (ringinuse=no)’. Selecting this option updated the option in the queue which therefore resolved the issue.