Provisioning problems


I am deploying a few sangoma phones S500 on remote sites and i am having issues.

Although the phones seems to getting an IP and are able to connect the portal to retrieve their configuaration they cannot register to FreePBX.

In the logs of the FreePBX i dont see anything.

Network connectivity is not an issue because i am able to ping from both sites and the connection is done through a VPN.

Any ideas please how do i start to troubleshoot this ?


Wireshark to see what is happening to the traffic coming from the phone for the registration. If you do not see anything on the FreePBX log, your traffic is being blocked before coming to the box.

Odds for he used a FQDN in EPM and it does not resolve the same at the remote site?

Remote sites are connected via a VPN to FreePBX, so i am using local IP address in EPM

No SIP traffic is shown at all, i took a trace from the phone and i dont see any SIP packages at all.

Narrow it down. Where does the traffic stop from the phone?

  • Are phones obtaining a local IP, does it match expectation?
  • Is the local IP set allowed through the local FreePBX firewall?
  • Are there network firewalls in place that could be blocking traffic?


First of all the IP phones are getting IP from a local DHCP server.
Access to is allowed from the router and of course i ve set all the remote networks in Asterisk SIP settings.

Also i ve se tthe remote networks in FreePBX firewall as zone LOCAL if that helps.

No firewall is blocking any traffic either to FreePBX or Sangoma portal

I ve set up HTTP provisioning without any authentication in Sangoma portal

In the Sangoma portal, you setup redirection to the local IP?

If you are not seeing the phones hit the FreePBX server in the log, its something before that. What about the phone logs? Does the phone have a log of what is happening as it tries to negotiate?

I’ve had many problems updating firmware ever since .62. Usually, I just keep rebooting and resetting the phone to factory default and it just works. I have also changed back to using tftp as I’ve not been having much joy with the http authentication.

Yes in the portal I ve setup a local IP for redirection.

The phones can genarate pcap traces but I don’t think there is a log.

@jasonmel are you saying that after factory reset and reboot it worked? Because I ve done many times factory reset and nothing happened.

What happens when you open a browser on the same network as the phone is, and go to the ip.address:port that you specified in the portal?

It says

You don’t have permission to access /.noindex.html on this server.

Is this correct

This is good.

Then there’s something wrong on the portal end.

Mind posting a screenshot of the config in the portal?

Problem solved

Found that firewall was blocking port 84

Thannks for your help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.