Problems making outgoing analog calls with TDM400P

freepbx
configuration
Tags: #<Tag:0x00007f702c7c3488> #<Tag:0x00007f702c7c30f0>

(Rwhillier) #1

Hello all,

I have a FreePBX installation, with a TDM400P card containing 2 x FXO modules and 1 x FXS module. I installed and configured this a couple of months ago, with a single FXO set up as a trunk (a BT line in the UK). All was working perfectly.

For some reason, about a month ago, outbound calls via the BT line stopped working properly. The destination phone would ring, but on answer there would be no audio at all. There would be no “ringing” sound on the calling party either. When the called party hangs up, the calling line gets a “all circuits are busy now” announcement.

I ran a Wireshark trace for the SIP messages, and noticed that immediately after the INVITE, there is a “401 Unauthorized” response, immediately followed by an ACK. This is immediately followed by another INVITE and a “100 Trying”, but no RINGING is received. Nothing else happens until I end the call.

Inbound calls are working fine (via an IVR), and calls to other SIP extensions are also fine (though I did notice the same “401 Unauthorized” when calling another extension, even though it connected fine).

I’m not sure of this is a SIP problem or a DAHDI problem. Even more curious is the fact that it worked fine, then suddenly stopped.

Has anyone come across this before?

Thanks,

Rob


#2

Is your analog like working correctly if you connect it directly to an analog phone?


(Rwhillier) #3

It is, yes. I’ve tested the line with a normal phone, and it’s fine. I’ve also tested it on two different lines, and with the seconds FXO module, but I get the same result. I’ll put together my DAHDI config and post shortly.


(Rwhillier) #4

chan_dahdi.conf
[general]

; generated by module
#include chan_dahdi_general.conf

; for user additions not provided by module
#include chan_dahdi_general_custom.conf

[channels]
language=en
busydetect=yes
busycount=10
usecallerid=yes
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=no
immediate=yes
faxdetect=no
rxgain=0.0
txgain=0.0
alawoverride_checkbox=0
boostringer=0
boostringer_checkbox=0
callprogress=yes
cidsignalling=v23
cidstart=polarity
echocan_nlp_max_supp=
echocan_nlp_threshold=
echocan_nlp_type=0
fastringer_checkbox=0
fxs_honor_mode_checkbox=0
lowpower=0
lowpower_checkbox=0
module_name=wctdm24xxp
mwi=none
mwi_checkbox=0
neon_offlimit=
neon_voltage=
opermode=uk
opermode_checkbox=0
progzone=uk
ringdetect=0
ringdetect_checkbox=0

; for user additions not provided by module
#include chan_dahdi_channels_custom.conf

; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

chan_dahdi_general.conf
Empty

chan_dahdi_general_custom.conf
Empty

chan_dahdi_channels_custom.conf
Empty

chan_dahdi_groups.conf
signalling=fxs_ks
context=from-analog
callerid=asreceived
signalling=fxs_ks
group=0
channel=>1

signalling=fxs_ks
context=from-analog
callerid=asreceived
signalling=fxs_ks
group=1
channel=>2

signalling=fxo_ks
context=from-analog
group=2
channel=>3

chan_dahdi_additional.conf
;;;;;;[220]
accountcode=
busycount=7
busydetect=no
callerid=Old Phone <220>
callprogress=no
context=from-internal
echocancel=yes
echocancelwhenbridged=no
echotraining=800
immediate=no
namedcallgroup=
namedpickupgroup=
signalling=fxo_ks
channel=>3

/etc/modprobe.d/dahdi.conf
options wctdm24xxp opermode=UK alawoverride=1 fxshonormode=1

Any help will be much appreciated