Problem installing SystemAdmin - ZendGuard and incrond

I have been trying to install FreePBX on a CentOS OpenLogic 7.2 Azure Virtual machine.

I have bee using the following url as a reference:

It has all gone very well. However, now that I am trying to install the modules, the standard modules install fine, but when I tried to install System Admin (via the Web UI), I got an error:

PHP Component Zend Guard Loader is required but missing from you PHP installation
The File “/usr/sbin/incrond” must exist

I followed the post PHP Component Zend Guard Loader issues and managed to install Zend Guard. I then did a:

cd /etc/yum.repos.d/
yum install incron

The above was found on

Afterwards, I was able to attempt to install System Admin, but received a mkdir Permission Denied Error message in relation to:


Can anyone point me in the right direction?

Hi jfinstrom, Thanks for the reply. I used the CentOS 6 version of this install recently and had “issues”. I am probably on my 20th install so far, and found the post on to be a bit more pleasing to my stress levels! I will give the CentOS 7 version a go on another VM. However, do you have any pointers as to how to fix the permission error that I am facing?

I assumed you were on a centos 7 derivative from your post. If you don’t have an express reason to build by hand I honestly recommend just using the Distro… it will save your sanity and your hairline

I wanted to install it to understand it better. However, I also couldn’t work out how to use a Distro on an Azure VM!

I have just finished configuring another server from the url, and have hit upon the exact same issue?

PHP Component Zend Guard Loader is required but missing from you PHP installation
The File “/usr/sbin/incrond” must exist

The only problem that I had with the script is the line:


I had to change this to:


Any ideas what I should do from here to be able to enable System Admin?

So I found the following:

It mentions that the commercial modules only work on the FreePBX Distro, but I cant use the Distro as its an Azure VM.

I tried following some of the commands, but there are only files available for CentOS 6 and not CentOS 7

So do I need to give up on this and revert back to CentOS 6?

I need System Admin, as I purchased End Point manager via my first go on a CentOS 6 VM, but there were many errors around TFTP, hence trying to start again on CentOS7

There are plenty of hosting providers that allow you to use Distro. Azure is not one of them. The easy question to ask is ‘Can I install this VM from an ISO’. If the answer is no, look somewhere else.

If you don’t want to use one of the FreePBX Hosting partners (See for the list) who look after your machine for you, I would personally recommend Vultr, as they’re cheap and cheerful, and rarely have problems.

Just to clarify: That’s a personal recommendation, not an official stance or anything. Really, you should be using a hosting partner. They have the ability to call us and wake us up if something is badly wrong.

However, if you DO want to use vultr, feel free to sign up using this link: – That’s my own, personal, affiliate link, and if you sign up using that, I get a few bucks credit added to my (personal) account.


Was this resolved? I am still getting the permission denied error while trying to install the systemadmin needed for the endpoint commercial module. CentOS 7, FreePBX 13 and PHP 5.4

Hi l0b0,

No, it wasn’t resolved. I went from issue to issue to issue. In the end I found a hosting provider that provided both an access control list functionality and install from ISO, and everything worked just fine. I honestly recommend not bothering to install it yourself.

I am in the UK, and I decided to go with ElasticHosts.

Hope that helps.

thank you for the reply, the thing is our PBX is in production and cant really switch to something else.

I installed FreePBX from scratch and almost went live with it. I thought the occasional unable to fork message here and there was just the way it was. Trying to install Endpoint Manager highlighted to me just how time consuming and error prone it was to iron out the issues from a self installed version. If you are live on a version that you installed yourself and don’t have any other issues other than with EndPoint Manager then I agree, try to resolve the issue. I did actually contact Sangoma support after purchasing the module and got some great free assistance. However, other issues manifested (the one from this initial post), and I therefore pulled the plug on it and started again.

I now have a production FreePBX that was installed from the distro, and I have had absolutely no issues whatsoever so far. After finding ElasticHosts to host it, it was up and running within a couple of hours.