Problem Afer update to FreePBX14

Hello, after upgrading to Freepbx 14, a major problem started.

When you restart the pc, it does not recognize the FXO board.
So I can not make or receive calls.

In principle when I put dahdi_tool nothing appears to me as if no board was connected.

Now what I have to do to start/excecute this steps

  1. service dahdi start ( after this step, the card appear on dahdi_tool)
  2. dahdi_genconf
  3. Then in the control panel enter the connectivity - DAHDi Config - Analog Hardware - press Edit button and then in the 4 buttons put
    Group 0 and in Context from-analog

Can anyone know what it’s like to fix it ???
What I miss the most is that it would seem that the dahdi service does not start with the system

That sounds very similar to the problem I have:

Unfortunately, I’ve not been able to get this fixed yet, and it’s being blamed on an incompatible card (which I’m not convinced about). What make of card do you have?

I don’t have to run ‘dahdi_genconf’ and reconfigure hardware settings to get it working. I just need to do a ‘fwconsole restart’ after doing the ‘service dahdi start’ and it all jumps back into life.

Hi Cahser, yes after try i dont need to run dahdi_genconfig

Only start the service and confire the gruop 0 and from analog

My card its a digium 4 ports.

Thanks

Ok, Sounds very similar to my issue, but in your case with supported Digium hardware. Hopefully because you’re running supported hardware, it might be easier to get a the developers to have a look at this.

To help narrow down the problem, after a reboot, can you type the following and post back the results.

[[email protected] ~]# /etc/init.d/dahdi status
[[email protected] ~]# echo $?

[[email protected] ~]# systemctl status dahdi
[[email protected] ~]# echo $?

If it returns an exit code of ‘0’, then this is meant to indicate ‘Dahdi is running’. If it returns ‘3’ this is meant to indicate that ‘Dahdi is not running’. In my case dahdi status is returning ‘0’ even when Dahdi is not running. systemctl status dahdi is correctly returning ‘3’:

[[email protected] ~]# /etc/init.d/dahdi status
[[email protected] ~]# echo $?
0
[[email protected] ~]# systemctl status dahdi
● dahdi.service - LSB: DAHDI kernel modules
   Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd-sysv-generator(8)
[[email protected] ~]# echo $?
3

I don’t know why the two different commands report different results, since ‘dahdi status’ is just meant to redirect to ‘systemctl status dahdi’.

From what I understand, the startup script uses ‘dahdi status’ during start up, and will only attempt a dahdi start if it returns a status of 3. Because ‘dahdi status’ is returning the wrong status, a dahdi start is not even attempted.

Good luck!

I reboot and excecute all you say and have the same result, i think its a bug on freepbx, i dont know what happend

[[email protected] ~]# /etc/init.d/dahdi status
[[email protected] ~]# echo $?
0
[[email protected] ~]# systemctl status dahdi
● dahdi.service - LSB: DAHDI kernel modules
   Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd-sysv-generator(8)
[[email protected] ~]# echo $?
3

Out of interest, did your update to FreePBX14 run smoothly, or did it hang up at any point?

If I recall, my update hung up at the point it was modifying the httpd.conf file. I eventually had to reboot the machine and manually fix some issues in the httpd.conf file (I think I had to remove a duplicate ‘Listen 80’ line) to get the web interface running.

I’m fairly certain the upgrade script didn’t finish correctly due to the forced reboot, because I then ran into a number of DAHDi issues. Most of these have been resolved by manually running some of the commands that should have been executed by the script. Unfortunately I still have the outstanding DAHDi startup issue, and I suspect this is due to missing a part of the upgrade that influences the way DAHDi is started in FreePBX14.

no, my update run perfect, dont have any problem with the update.

@tm1000 - Along with me, this is the third person to report this problem. In this case, Digium hardware is being used. Should I raise a bug report?

i already create a report bug
https://issues.freepbx.org/browse/FREEPBX-15966

but not response yet

@chaser @glew

In the ticket it says

Thanks for creating a report! The issue has entered the triage (open) process. That means the issue will wait in this status until the FreePBX team has an opportunity to review the issue. Our weekly triage meetings happen every Monday. Once the issue has been reviewed you may receive comments regarding the next steps towards resolution.

ok, thanks

I’ve just finished a fairly large System Update, and this has solved the problem for me. Here is my new version details:

Current PBX Version:14.0.1.15
Current System Version:12.7.3-1708-1.sng7  
Total Module Count:119
Enabled:117
The numbers below may be inaccurate if new modules have been released since the last check:

Last online check:2017-10-05T23:32:39+00:00
Modules with Upgrades:0
System Upgrades Available:0

The PBX already update but i have only 108 module enable but, when i see the modules not are no one disabled.

 Current PBX Version:14.0.1.15
Current System Version:12.7.3-1708-1.sng7  
Total Module Count:117
Enabled:108
The numbers below may be inaccurate if new modules have been released since the last check:

Last online check:2017-10-06T20:12:39+00:00
Modules with Upgrades:0
System Upgrades Available:0

I wouldn’t worry too much about the number of modules you have. I may have manually added some more.

So I assume DAHDi is still not loading for you? Can you check what version of wanpipe driver you have running on your system:

[[email protected] ~]# yum list kmod-wanpipe.x86_64 wanpipe.x86_64

If it comes back with version 7.0.20.13-1.sng7 AND DAHDi is still not loading correctly for you, you may want to try:

[[email protected] ~]# yum downgrade kmod-wanpipe.x86_64 wanpipe.x86_64

which will bring you back to version 7.0.20-9.sng7. This is what has worked for me. You can always upgrade them back to the latest version later with a yum update if it didn’t work for you.

Note that there’s a lot of discussion about this issue just now, and what I’ve posted above is just a work around that works for me. If you don’t have any Sangoma hardware (and I don’t think you have. I think you have digium hardware), then the wanpipe driver shouldn’t be having any influence on DAHDi, but at least in my case it certainly seems to be having an influence.

i make a mistake,
i put yum remove kmod-wanpipe.x86_64 wanpipe.x86_64
after that yum install kmod-wanpipe.x86_64 wanpipe.x86_64

After that, the dependencies of freepbx and sangoma-pbx, dosent appear.

So i put yum install freepbx yum install sangoma-pbx.

i already make the downgrade of kmod-wanpipe.x86_64 wanpipe.x86_64

but still have the same problem, after reboot y need to make the fwconsole restart manually

the only change is this, after reboot if i excecute the

[[email protected] ~]# /etc/init.d/dahdi status
[[email protected] ~]# echo $?
[[email protected] ~]# systemctl status dahdi
[[email protected] ~]# echo $?

Now say all correct

[[email protected] ~]# /etc/init.d/dahdi status
### Span  1: WCTDM/0 "Wildcard TDM410P" (MASTER)
  1 FXO        FXSKS       (EC: VPMOCT032 - INACTIVE)
  2 FXO        FXSKS       (EC: VPMOCT032 - INACTIVE)
  3 FXO        FXSKS       (EC: VPMOCT032 - INACTIVE)
  4 FXO        FXSKS       (EC: VPMOCT032 - INACTIVE)
[[email protected] ~]# echo $?
0
[[email protected] ~]# systemctl status dahdi -l

● dahdi.service - LSB: DAHDI kernel modules
Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
Active: active (exited) since Sat 2017-10-07 09:53:32 UTC; 21min ago
Docs: man:systemd-sysv-generator(8)
Process: 1375 ExecStart=/etc/rc.d/init.d/dahdi start (code=exited, status=0/SUCCESS)

Oct 07 09:53:32 localhost.localdomain dahdi[1375]: wcb4xxp: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: wctc4xxp: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: xpp_usb: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: r1t1: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: rxt1: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: rcbfx: [ OK ]
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: D: auto '/sys/bus/dahdi_devices/devices/pci:0000:02:05.0’
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: auto-assign /sys/bus/dahdi_devices/devices/pci:0000:02:05.0
Oct 07 09:53:32 localhost.localdomain dahdi[1375]: Running dahdi_cfg: [ OK ]
Oct 07 09:53:32 localhost.localdomain systemd[1]: Started LSB: DAHDI kernel modules.

[[email protected] ~]# echo $?
0

but i need to make fwconsole restart to make and receive calls

Not sure what you’ve done! It sounds like DAHDi is now loading on reboot. To confirm, try the following commands after a reboot, and report back:

dahdi_cfg -vvvv
asterisk -rx "dahdi show status"