Position number of caller not being played in Queue Announcement, works only for 1st in line


(Chiel) #1

Hello,

I have a queue where I enabled “Announce Position”.

This works great for the caller that is in position 1. The announcement played is: “Your call is now first in line and will be answered by the next available representative, thank you for your patience”.

The next persons that joins the queue gets: “You are currently caller number … waiting to speak with a representative, thank you for your patience”.

So the position in the queue is not played.


(Dave Burgess) #2

Check the logs and see if the rest of the number sound files are being correctly referenced. It could be a weirdness in a foreign language instance or something else that’s simple to resolve. You should see the sound files getting played back to the queue rider in the logs (/var/log/asterisk/full).


(Chiel) #3

I checked with “asterisk -rvvvvv”.

For the first caller it will play correctly:

– <PJSIP/voip-server-00000006> Playing ‘queue-youarenext.alaw’ (language ‘en’)
– <PJSIP/voip-server-00000018> Playing ‘queue-thankyou.alaw’ (language ‘en’)

But for the next caller the fallowing is displayed:
– <PJSIP/voip-server-0000001b> Playing ‘queue-thereare.alaw’ (language ‘en’)
[2020-10-05 12:04:24] WARNING[14841][C-00000011]: file.c:789 ast_openstream_full: File digits/2 does not exist in any format
[2020-10-05 12:04:24] WARNING[14841][C-00000011]: file.c:1262 ast_streamfile: Unable to open digits/2 (format (ulaw)): No such file or directory
– <PJSIP/voip-server-0000001b> Playing ‘queue-callswaiting.alaw’ (language ‘en’)
– <PJSIP/voip-server-0000001b> Playing ‘queue-thankyou.alaw’ (language ‘en’)

It seems that it can’t find a particular file. I didn’t make any changes to Language settings. When I check “Global Language” it is set to “English”. For the Download Format “g722” and “ulaw” are selected.


(Communication Technologies) #4

Add the missing file (from another pbx install, or record one yourself).

/var/lib/asterisk/sounds/en/digits


(Dave Burgess) #5

You could also log into the console and try something like this:

find /var/lib/asterisk/sounds -name '[0-9].alaw'

Once you find them (and I’m pretty sure they’re there somewhere) you can use the following to get them to where you want them to go:

cp <pathname to file>/[0-9].alaw /var/lib/asterisk/sounds/en/digits/

It’s weird that the files aren’t there, though. Something else is going on.


(Chiel) #6

Thanks! The directory “/var/lib/asterisk/sounds/en/digits/” was missing… very strange! Didn’t make any changes to any files.

Copied them from another server, changed the permissions, and now it works :slight_smile:


(Communication Technologies) #7

Great, don’t forget to mark your question resolved, if it is.