Polycoms not saving log files

None of my polycom phones are saving their log files to the tftpboot directory. I’ve edited the basefile in EPM (and rebuilt configs) where the mac.cfg file has the setting for LOG_FILE_DIRECTORY="" No logfiles are saved with the value as “” or as “/logs” or as “/logs/”.

I chmodded the tftpboot directory to 777 but still no joy.
Am I missing something?

1 Like

The TFTP server config file doesn’t have the -c option by default. That is what is needed to allow the logs to write to the TFTP directory.

option -c? Is that something to specify in the dhcp settings? Where do I set that? (I’m trying to google up the answer)

It would be right where I said it was. In the TFTP config which would be in /etc/xinetd.d so you should be Googling about TFTP not about DHCP.

Okay, I added the option in server_args:
server_args = -v -s -c /tftpboot
and restarted the service.

But the phone still doesn’t generate a log file there.

Watching the tcpdump, I can see the phone making write requests to the correct location. Even if I don’t specify the tftpboot/logs folder and leave LOG_FILE_DIRECTORY="", it still doesn’t write logs. It is able to fetch all it’s bootroms, however.

[[email protected]/]# tcpdump port 69 -v
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
19:35:34.279561 IP (tos 0x0, ttl 64, id 2272, offset 0, flags [none], proto UDP (17), length 62)
    192.168.1.136.danf-ak2 > mypbx.tftp:  34 WRQ "logs/0004f20588dd-app.log" octet
19:35:35.579788 IP (tos 0x0, ttl 64, id 2318, offset 0, flags [none], proto UDP (17), length 57)
    192.168.1.136.afrog > mypbx.tftp:  29 WRQ "0004f20588dd-app.log" octet

So, the -c option did not work, unless there is something I have to do besides restart the tftp service.

tail -f /var/log/messages | grep tftp <-- watch live output of the log file for tftp requests
grep tftp /var/log/messages <-- get all tftp requests in the log file.

You should see the WRQ and what the reason/response was to it from the TFTP server.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.