Polycom phones via http and HTTPS


(Rob Thomas) #1

As I hate tftp with a passion, I deployed some Polycom phones using https, and discovered that they are trying to write stuff to the web server using HTTP PUT.

This needed me to throw a little script together that handles it, and it’s available here:

Enjoy!


Https provisioning + client denied by server configuration
Polycoms not saving log files
Backup Yealink Local Contacts to provisioning server
(Jared Busch) #2

interesting. I have been arguing with a Polycom this morning trying to make it use HTTP manually because DHCP options point to the live PBX not the new one I am setting up.

I wonder if this will help me.

Thanks!


(Rob Thomas) #3

Nope. I had the same problem. If you’re using commercial endpoint manager, you want to add these (but it STILL uses DHCP, but at least this can persist the changes):

set @models='IP301, IP320, IP321, IP330, IP331, IP335, IP4000, IP430, IP450, IP5000, IP501, IP550, IP560, IP6000, IP601, IP650, IP670, IP7000, VVX1500, VVX300, VVX310, VVX400, VVX410, VVX500, VVX600';
set @template='default';
set @url='pbx.example.com:4443'
set @username='12345';
set @pass='98765';
set @proto='HTTPS';
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'prov', 'device', 'PARENT', 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'password', 'device.prov', @pass, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'password.set', 'device.prov', 1, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'user', 'device.prov', @username, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'user.set', 'device.prov', 1, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'serverName', 'device.prov', @url, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'serverName.set', 'device.prov', 1, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'serverType', 'device.prov', @proto, 1);
insert into endpoint_basefiles (brand, template, model, file, define, param, attrib, value, edited) values ( 'polycom', @template, @models, 'features', 0, 'serverType.set', 'device.prov', 1, 1);

You can do the same thing through the GUI, but it was much quicker to do it that way, as I had a bunch of templates I had to update.

If you figure out the param to tell it to IGNORE DHCP Option 66, that would be great - I’ve tried setting it to ‘custom’ and option 254, and that still seemed to trust DHCP more than the settings.


(Jared Busch) #4

For the record, dealing with Polycom makes me want to cry…


(Rob Thomas) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.