Polycom VVX310 phones won't register in Freepbx 15 using Asterisk 17

I have a Freepbx 15 and Asterisk 17 free distro box that I built for a church and the system for some reason cannot register Polycom VVX310 phones using version 1.11 firmware. I’ve been at this for three days now and cannot get these phones to register. I was using PJSIP extensions but converted them all to Chan_SIP on port 5160.

I checked to ensure that all phones had their respective files in /root/tftpboot and they are all there with correct contents. I’m using EPM (paid version) 15.0.27.32 and all modules and yum updates are current.

I’ve also gone into the phones’ web consoles and moved them to tftp with no user name or password and with and without the server address. Nothing works. Am I fighting a battle that can;t be won? Is there possibly just a “this doesn’t work with that” scenario in place here? Any advice is greatly appreciated.

One last thing, the phones are using the Windows Server DHCP as their IP source and Option 66, 160, and 161 are all in the scope options and pointing to the Freepbx server’s IP address.

Thanks.

In theory, it should work… however, your mileage may vary depending on several factors, one mainly being how your phone to pbx communication is laid out logically.

The phones, even when using EPM, need to first be logged from the phone using extension and pw, make them point to 5160 and use udp. Set your RTP ranges to within 10002 and 19998 (even numbers). Once the phones register successfully, reboot them. Once the phones reboot, they should see the dhcp opt 66 and be able to hit the server up for firmware/template updates. Make sure the template for that exact make and model is up-to-date in EPM as well.

If you are unsure of how to do this, you may PM me.

It’s hard to help, because your post details what you tried, but not what you observed.

And do other phones, softphones or SIP apps register ok?
Do the phones show the expected label on their screens?
Does the phone’s web interface show the correct extension number and server address?
Does the Asterisk log show any entries when the phones attempt to register?

Because of what observation?

And did the log in /var/log/messages show that tftpd served the files?

Have you tried to configure one phone manually from its web interface (not all the fancy stuff, just enough to register one line to make and receive calls)?

When I prepared that box, all I did was configure the polycom template, define the buttons in the VVX310 model, and then run the Network Scan. It picked up all the phones. I assigned extensions to them along with the template and model, rebooted that phones and they provisioned with no issue.

That box was hit last week with a surge and fried. The church bought a new PC, I downloaded the newest free distro and re-installed everything. The box is up and running and is completely up to date, but the phones won’t register.

They do show up with the extension on the displays, and the admin password is 222222, but in Extension Mapping, the IP address is blank (I set in Global Settings to see the IP address and response time) and the phones have X for each of the two lines. Strangely enough, I also configured the right three buttons to handle parking, but no Park, Park 1 or Park 2 labels appear, just the line buttons.

The church has only 10 phones and they don’t use softphones and I don;t have a non-Polycom phone to test to see if that will provision.

I don’t understand “the phones need to first be logged from the phone using extension and pw.” If it’s using TFTP, there is no need for user name and password, correct?

Thanks for the reply. It’s a small church with only 10 Polycom VVX310 phones. They don’t use softphones and I don’t have another brand of phone to test provision.

The phones do show the line labels on their displays, but not the Park, Park 1 and Park 2 labels I configured on buttons 4, 5 and 6.

I switched from PJSIP to SIP to see if that was the cause of the phones not provisioning. Also, I found this post and saw that as evidence – Polycom VVX PJSIP.

I’m a relative newbie (1.5 years experience) and I did not check the /var/log/messages because I’m not yet well-versed on all the various troubleshooting methods. I will check that, though.

I did try several manual configurations both onsite on the phone and also through the web console. Nothing worked.

This is not true. You don’t need to manually configure sip registration details on a phone when using EPM. The only scenario where this would accomplish something would be in the case of provisioning a phone from a non-white listed source IP thru responsive firewall. In such a situation, it would be preferable to just white list the phone IP.

@gabosch you are provisioning via tftp, ensure that tftp is enabled as it’s disabled by default on a new modern install. Alternatively, I would suggest you don’t use TFTP at all, and provision using http with a URL of the format:

http(s)://username:[email protected]:port

The apache details are configured in System Admin and summarized in EPM global details.

I tried what you suggested, Lorne, but still no registration. I got the httpusername and httppassword from the Sysadmin Provisioning Protocols page, entered the URL in the Polycom template provisioning server custom field as https://httpusername:[email protected]:1443, went into the Polycom web console and set them to factory default, then removed them from Extension Mapping and rescanned and readded them. I have no clue why these phones aren’t provisioning.

Get them working with http before attempting HTTPS.

I did attempt that first, before moving to HTTP. No success with either method. I am offsite from the system in question and can no longer reach the phones’ web consoles because I reset them to factory defaults before I tried the HTTP/HTTPS provisioning. There were too many settings adjustments made so I wanted them to be clean for the attempt you recommended. Thanks for your advice.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.