I have migrated an old Freepbx system to a new one (version 14) and I am trying to switch the extensions from CHAN_SIP to PJSIP. All extensions are working using CHAN_SIP. However when I switch one I cannot get the phone to register. I am getting the following error:

Registration failed User: 116, Error Code:480 Temporarily not available

I am using the EPM and basically used the defaults for both EPM and the PJSIP Extension setup. Any ideas?


Probably it did not “switch” correctly or completely - simple fix - go into advanced for that extension, hit “Change to SIP” and submit - submit again like you have to.

Then go back into Advanced, hit “Change to PJSIP” and then submit and then submit again.

Finally hit apply, and then the phone should be fully switched and the endpoint .CFG’s should be right.

I set this extension up from scratch so I don’t think that is the issue but as a test I did convert the extension back to CHAN_SIP got it working then converted it back to PJSIP and still get the same error.

I did a comparison of the cfg files from the CHAN_SIP extensions and the PJSIP extensions and there is no difference in the generated polycom configs.

The phone system is on the cloud but not behind a firewall, it is just using the builtin responsive firewall however the phones are behind a Sophos firewall at two different sites.

When I enabled the PJSIP setting under Advanced I did reboot the server.

When rebooting the phone I don’t even see anything in the Asterisk -rvvvvv debug where it is trying to connect.


There has to be a difference in the Port it is trying to register against - SIP and PJSIP can not be on the same port - go into SIP settings and confirm what port each is listening to.

There is no way they would be the same - the port would HAVE to be different unless something is not set correctly.

Check it’s port number. It probably didn’t get updated.

Ok, well I am sure it is documented somewhere but I did not know that CHAN_SIP and PJSIP can’t use the same port to bind to so once I rebooted the server I hosed all the CHAN_SIP connections including my inbound SIP trunks and low and behold the Asterisk Dashboard did yell at me.

After I set the two sip types onto different ports the phone was still not working and I was ready to bash it off the desk but I calmed down and started exporting the configs on the VVX. I found that it had harbored old static settings on it from the previous phone system. Once I reset it to factory defaults and it grabbed all the settings from the provisioning server it started working.

Thanks to everyone who responded now someone just needs to update the FreePBX wiki that the SIP drivers need to be on different ports and when changing that setting to that the server needs rebooted.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.