Polycom VVX 600 with Color Expansion Module


(Erich Beckmann) #1

I have seen this issue brought up several times and it always seems abandoned before reaching a solution. The last thread I saw ended with “I’ll report back”…

So, I’m using FreePBX with several clients with mostly Polycom phones deployed.
I have a new client who wants to switch their service to us but they are currently using the VVX Color Expansion Modules on three of their phones. I’ve never gotten them to work in my lab but I want this client so I’m back at it again.
The problem is exactly the same as Paulbzero’s problem here: Polycom VVX Expansion Module

I have ordered two RJ12 6P cables to test and I have several other VVX Color Expansion Modules in storage from the last time I tried to get them working.
The phone I am using is a VVX600 and I have so far tried the latest firmware from Polycom (5.9.6) as well as 4.1.8.0628, and 5.5.1 (the latest to be built into FreePBX) to no avail.
The VVX Color Expansion Module remains a blank screen.
The phone recognizes when the Exp Module’s buttons are pushed and I can push a logo to the screen but no lines, BLF, or BLF-Xfer configurations.
I have tried padding out the config with nonsense BLF configuration keys as suggested in another post but that did not work.
In the web interface of the phone I see a list of the configured keys that should appear on the Exp Module but they do not display on the module.
Any help with this would be greatly appreicated.

Thank you!


(Luke C) #2

You have to fill up ALL the 600 lines, then the expansion module will start to populate.


(Paulbzero) #3

Hi @ebeckmann, thanks for the thread mention. I forgot to update that thread with my fix, and now it’s locked due to age.
In my case I was using a VVX 400. It turned out the jack on the phone was bad. I swapped it with another VVX400, and the sidecar worked beautifully, and still does to this day.
Also, be aware of power limitations if you’re running PoE. Our switch is not PoE+; I had to use an injector that plugged into the wall next to the phone with the sidecar. If you’re running long cables you might experience a voltage drop and cause the phone or sidecar to behave weirdly.


(Lorne Gaetz) #4

I’ve reopened if you want to update with your findings.


(Erich Beckmann) #5

Awesome! Thank you for the information. I will try different phones, external power supply, etc as you have suggested and report back as soon as possible.

Thank you very much for both responses!


(Erich Beckmann) #6

Success with a VVX 411 and a VVX Color Expansion Module on a Unifi PoE Switch on a six foot cable. The phone and sidecar consume about 4W when idle.

YES, I had to fill up all of the buttons on the VVX411 before it would spill over to the Exp Module so, thank you for that tip.

The firmware I am running on the VVX 411 is: 5.5.1.15880
I’m going to try some other permutations of phones and power sources. I will report back to this thread for anyone else that can benefit from the findings.


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.