PMS expired/renewed... now Module Updates Busted... stuck in on dependencies

Module updates would not work for a few modules. Noticed that Endpoint Manager update license expired. Purchased license for 1 year… activation updated:

Endpoint Manager - Expiration Date 2047-02-17 (Updates and support until 2024-07-20)
EPM for UCP - Expiration Date 2047-02-17
System Admin - Expiration Date 2047-02-17

Go to update the modules, but the Phone Apps (restapps), SangomaConnect and Sangoma Realtime API are disabled (pending upgrade)… Both Sangoma’s need restapps upgraded, restapps needs EndPoint Manager upgraded from to or higher…

Using the GUI, there is no option to upgrade Endpoint manager, only to Force Download and Install… Can’t disable or uninstall…

if I try to upgrade using CLI, it tried to upgrade to, but then… Installing Missing Dependency of: restapps 16.0.10… the following error(s) occured: Endpoint manager module version or higher is required Unable to resolve dependencies for module pms

I have tried what I could find online to try to resolve this but it’s isn’t going… I’ve tried to switch to Edge mode… but never the option to update using the GUI… just the cli and that seems to be complaining about dependencies and I can’t uninstall anything or Force the upgrade…

Any suggestions?

Try fwconsole ma updateall --force in the CLI.

You have to be kidding me… fastest response ever… and it worked (mostly)!

Endpoint Manager is still on and won’t upgrade to… doesn’t list it as an option in the GUI and I don’t see popping up in the CLI either, just the current installed version… Rebooted server, same… Maybe I am wrong to assume this version difference is an issue…


fwconsole ma downloadinstall endpoint --tag=
1 Like

No repos specified, using: [standard] from last GUI settings
Unable to update modeule endpoint -, it does not exist:
updating hooks… done
Chowning directories… done

Not 8.12, 80.12.

Sorry, I mis-typed in my posting… it was correct in the cli… 80.12… I also tried some older versions 80.11, etc… to see if it was something to do with the latest… same results.

How about

I guess are you still running into any sort of problems at this point?

Same error as above “it does not exist”… almost like the repo doesn’t have it…

Sorry, to clarify… I don’t see problems at this point… but there seems to be a lot of versions between the one running on the server vs the current version. Odd that paid to get the updated version, yet it’s the one stuck on the old version… Maybe I will give it a few days and re-visit it…

Are your maintenance payments current on endpoint. It would have to be renewed to get an update

As per original post… I assume Updates until next year means maintenance?

After you have a support expired license, then you purchase updates, although it shows in the GUI immediately, the license servers allowing you to download updates does not “kick in” for up to 24 hours.

1 Like

Makes sense. Thank-you… Also thank-you Igore for all your help. Much appreciated.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.