PM2 Installation driving me nuts!

Read through sooooo many of the PM2 installation posts now and still not getting this resolved. PM2 installation just times out, every other module installs fine. Did manual mode, Module admin mode, what else an I try ?? Error log:

Session terminated, killing shell...The process "runuser 'asterisk' -s '/bin/bash' -c 'cd /var/www/html/admin/modules/pm2/node && mkdir -p /home/asterisk/.pm2 && mkdir -p /var/www/html/admin/modules/pm2/node/logs && export HOME=/home/asterisk && export PM2_HOME=/home/asterisk/.pm2 && export ASTLOGDIR=/var/log/asterisk && export ASTVARLIBDIR=/var/lib/asterisk && export PATH=$HOME/.node/bin:$PATH && export NODE_PATH=$HOME/.node/lib/node_modules:$NODE_PATH && export MANPATH=$HOME/.node/share/man:$MANPATH && npm install --only=production'" exceeded the timeout of 600 seconds.

Also tried with and without proxy settings and manually downloading module, still no luck !

Removing the module after the failed install (using either Module admin or manual mode) does remove all traces of it. Re-installing using any method re-creates the folders but it never completes it …

Which version of FreePBX?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.