Please enter your password and then press pound

I had everything set up correctly (or so I thought).

I have a ring group that rings two PBX extensions and two PSTN cellphones. When I call our DID from the cellphones, the extensions ring for about half a ring and then goes to a voice saying “Please enter your password and then press pound”. If I pick up an extension phone before that half ring is done, the call connects. If the call is not caught in time it doesn’t register as a missed call.

I have this ring group set in a time group and time condition for normal business hours. When the time condition changes to going straight to a voicemail inbox (outside the time condition), it works correctly. The call connects and I can leave a voicemail.

At first I thought I was getting redirected to a voicemail inbox somehow but our voicemail passwords are not accepted in whatever menu this is. I have attached a log of a call from a cellphone below:

This is messing things up because now I am unable to call in and check voicemails or call our DID from the cellphones in the Ring Group.

Your mobile carrier is seeing an incoming call from your own mobile number, which it assumes means that you want to retrieve your mobile voicemail. If you enter your mobile voicemail password, you’ll be taken to its menu.

There are many approaches to fixing this:

One is to set up an second Inbound Route for your DID, with your mobile number (in the format that Flowroute sends it) in the Caller ID field. This routes to a Ring Group that rings the extensions and your partner’s mobile (but not yours). A third Inbound Route matching your partner’s mobile number would route to a Ring Group that rings the extensions and your mobile (but not hers). This bypasses the time conditions, so you can easily call in after hours when needed.

Another option is to set Confirm Calls for the existing Ring Group. This will require you to press 1 when answering any call from the PBX on your mobile. Yes, it’s a nuisance, dangerous to do while driving, and you’ll need to increase the Ring Time to allow you to confirm before the call gets sent to FreePBX voicemail. However, if you want to be sure that customer calls are never sent to mobile voicemail, it’s needed. Otherwise, if your phone is out of range, has a dead battery, was inadvertently turned off, or is placing a not-yet-answered call, your mobile operator’s voicemail will answer the call immediately.

A third choice is to route calls from both of your mobiles to a DISA. You could dial the desired extension, or make an outside call e.g. to a customer that would show your business number.

Don’t place a call from your cellphone when you are trying to call your cellphone. Simple fix: use an other phone for testing.

the issue is your caller id. if you call a cell phone and the caller id is the id of the cell phone, the cell phone goes straight to voicemail. my guess is you are calling in from your cell phone and one of the two pstn cellphones is the one you are calling from

I have gone with the DISA option and it is still going to my cell carrier’s voicemail prompt when I call (the cellphones are still in the ring group).

When I remove the cellphones from the ring group the DISA works correctly.

Is there some way to direct calls made from the cellphones to the DID to the DISA while at the same time ringing the cellphones if the DID is dialed by any number that is not one of the cellphones?

I don’t completely understand.

I assume that you have separate inbound routes that route incoming calls from your cellphones to the DISA and calls from other numbers to the Ring Group. If that is not working correctly, please explain.

Once you reach the DISA, you can then dial an extension number and it will ring just that extension. If you want to ring both extensions and the other cellphone simultaneously, define another Ring Group with those destinations. You would then dial the number of the new ring group from the DISA. The old ring group would still be used when customers call the DID. If that’s working ok, add a third ring group that your partner would use, which rings both extensions and your cellphone.

If you still have trouble, post a description of your routes and ring groups.

Stewart1, first off thanks a lot for the patience and explanations.

After playing around with it more, I believe the problem of cellphones trying to call themselves has been solved thanks to your suggestions.

I have tested calling into the DISA and then calling out to another number (as is desired because we want calls to have our company Caller ID information) but the Caller ID information that shows up on the called phone is my cellphone number. Any ideas why this might be happening?

DISA > Override caller ID option, set it to the opposite of what it’s set now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.