Phone Does Not Stop ringing After A Hang up

If I call from outside and end the call before someone picks up, the phone would continue ringing non-stop. I have monitored it for 3 minutes after I ended the call.

This only happens when the calls come through the IVR. When I change the destination to just an extension, the calls end right after the hang-up.

Any Ideas on why this might be happening? I will put in the logs later on today.

https://drive.google.com/file/d/1K8fC0us-Tuw8s3jsb_hvDh4YzjsqwHbO/view?usp=sharing
The above link is for Logs

Share logs via pastebin.freepbx.org

1 Like

https://pastebin.freepbx.org/view/203e2f34

Your GXW is not detecting disconnect from Lime. Possibly, the settings for Enable Current Disconnect and/or Enable Tone Disconnect are incorrect. If you answer a call normally and the caller then hangs up, what does the extension user hear?

If a disconnect tone is played but the GXW doesn’t detect it, you need to change the call progress tone settings.

If there is no disconnect tone, there may be a loop current disconnect; try setting a lower threshold or check with a voltmeter.

If you have neither disconnect tone nor current disconnect, you may be out of luck. Set the extension to go to voicemail after e.g. 25 seconds so the phone doesn’t keep ringing obnoxiously. The voicemail logic will hear only silence so you won’t get a useless message.

Okay I will try what you suggested.

So why is that it works fine without the IVR, I find that strange. (assuming that you know) :sweat_smile:

I speculate that once the PBX answers the channel you get different behavior. If a call goes direct to an extension, the channel remains unanswered until the extension picks up. You can test this hypothesis by enabling a force answer on the inbound route to see if you get different behavior.

noted I will test out that theory

Tone Disconnect is what is enabled on my GWX. It uses the busy tone. I’ve tried adjusting but no change.

@lgaetz Enabling force answer did not cause a change.

The expected change is to break the direct to extension case; did you try that.

Incidentally, I almost replied to the initial post suggesting the reason was that you were using an analogue line with faulty disconnect supervision, but couldn’t explain the IVR difference, but the above explanation makes sense to me. Saying that the call was from an analogue line was a rather important missing piece of information. The normal assumption is that people who don’t say are using SIP.

I dont fully understand what you meant by “to break the direct to extension case”.

Oh sorry about that (Rookie moves). Nice observation there, I’ll keep that in mind for the future.

The suggested change wasn’t intended to make the IVR case work, but to prove the theory by making it so that direct to extension calls failed in the same way as IVR ones.

Ahhh I see, I misunderstood that. So after setting force answer it did actually cause it to fail just like the IVR.

1 Like

OK, confirm that you hear the tone when on a call and the caller hangs up. It should sound the same as when you play
https://www.3amsystems.com/World_Tone_Database?q=Saint_Lucia,Busy_tone

-11 seems high for the level. See whether replacing with -20 helps. If no luck, record a call including a few seconds of disconnect tone and post the audio file (as a .tgz).

I can confirm that I hear the tone but Changing to -20 also didn’t help. how do i download the recording as a tgz file?

1.tgz (175.1 KB)

The .wav file has the expected frequency (425 Hz), expected cadence (0.5 s on, 0.5 s off) and reasonable level (-15 dBm, where 0 dBm is a ‘digital milliwatt’). So I don’t understand why disconnect tone is not being detected. Possibly, the FXO Line Analysis didn’t run correctly. Try running it again, capture the syslog output and post that.

Or, if you created or edited the values manually, something may be in an unexpected format.

You are not the only one with this problem; there is some interesting reading at
https://www.google.com/search?q=gxw4104+tone+disconnect
One poster fixed it with newer firmware; make sure that yours is current. Another was successful with f2=425. Yet another couldn’t get disconnect tone to work but used dial tone instead (after playing disconnect tone for a few seconds, his carrier plays dial tone).

Another thought: This might be a FreePBX problem, if Asterisk was sending an incorrect IP address in the Contact header of the 200 OK response to the incoming INVITE from the GXW. That would cause Asterisk to not ‘hear’ the BYE request sent by the GXW.

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, after Submit and Apply Config, you must restart Asterisk.

You can view the SIP traffic with the Asterisk command
sip set debug on
which will then include a SIP trace (along with the regular entries) in the Asterisk log. Or, look at the syslog output from the GXW to see whether it detects the disconnect tone and attempts to send a BYE.

I already did the line analysis but I will do it again. I have also tried the manual input by coping what I had set on another PBX which works just fine (Still made no difference).

Take a look at the GXW syslog output for a failing call. That will at least tell us whether disconnect tone was detected and whether it attempted to send BYE.