PBX Activated, but not Activated


#1

This is with FreePBX 15.0.16.76

During activation it for some reason it wants to use port 80 while using port 443 (https). However, port 80 is not reachable.

So I retried, and I get the following popup

Existing Deployment Found!

Deployment xxxxxxxx is currently assigned to this machine and is available for activation.

Again, it wants to use port 80, and won’t activate. So I got an a-ha moment and did this in the CLI

fwconsole sa a xxxxxxxxx

Successful registration so then I head back to the Web GUI, and bam! again.

Existing Deployment Found!

Deployment xxxxxxxx is currently assigned to this machine and is available for activation.

What’s going on with this?

More info. When trying to redo the activation, I see the following popup

We have identified that the admin port has been changed to 80. The wizard will try to automatically redirect to the new port, but if that doesn’t work, click on the ‘Continue’ button to redirect manually.);


#2

I am running into the same thing… have you had any luck with this?


#3

Yes, it has to do with the /etc/httpd/conf.d/schmoozecom.conf file

 # Automatically Generated File - 1604986233
 # {"acp":{"port":"8080","dir":"\/var\/www\/html"},"ucp":{"port":"128","dir":"\/var\/www\/html\/ucp\/"},"restapi":{"port":"143","dir":"\/var\/www\/html\/restapi\/"},"restapps":{"port":"135","dir":"\/var\/www\/html\/restapps\/"},"hpro":{"port":"131","dir":"\/tftpboot\/"},"leport":{"port":"disabled","dir":"\/invalid\/folder\/name"}}
 # Do NOT edit this file as it is auto-generated
 # Starting acp
 # acp
 Listen 8080
 <VirtualHost *:8080>
   Alias /.well-known /var/www/html/.well-known
   Alias /.freepbx-known /var/www/html/.freepbx-known
   RewriteEngine on
   RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
   RewriteRule (^\.|/\.) - [F]
   DocumentRoot /var/www/html
 </VirtualHost>
 # Starting ucp
 # ucp
 Listen 128
 <VirtualHost *:128>
   Alias /.well-known /var/www/html/.well-known
   Alias /.freepbx-known /var/www/html/.freepbx-known
   RewriteEngine on
   RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
   RewriteRule (^\.|/\.) - [F]
   DocumentRoot /var/www/html/ucp/
 </VirtualHost>
 # Starting restapi
 <DirectoryMatch "^/var/www/html/restapi/rest.php">
   AllowOverride None
   <IfModule mod_authz_core.c>
     <FilesMatch "^rest.php$">
       Require all granted
     </FilesMatch>
     Require all denied
   </IfModule>
   <IfModule !mod_authz_core.c>
     <FilesMatch "^rest.php$">
       Allow from all
     </FilesMatch>
     Deny from all
   </IfModule>
 </DirectoryMatch>
 <Directory "/var/www/html/restapi">
   DirectoryIndex rest.php
 </Directory>
 # Warning - The directory '/var/www/html/restapi/' doesn't exist
 # restapi
 Listen 143
 <VirtualHost *:143>
   Alias /.well-known /var/www/html/.well-known
   Alias /.freepbx-known /var/www/html/.freepbx-known
  RewriteEngine on
   RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
   RewriteRule (^\.|/\.) - [F]
   DocumentRoot /var/www/html/restapi/
 </VirtualHost>
 # Starting restapps
 <DirectoryMatch "^/var/www/html/restapps/(applications\.php|image\.php|restapps\.php|sync\.php|.+\.zip)">
   AllowOverride None
   <IfModule mod_authz_core.c>
     <FilesMatch "^(applications\.php|image\.php|restapps\.php|sync\.php|.+\.zip)$">
       Require all granted
     </FilesMatch>
     Require all denied
   </IfModule>
   <IfModule !mod_authz_core.c>
     <FilesMatch "^(applications\.php|image\.php|restapps\.php|sync\.php|.+\.zip)$">
  Allow from all
     </FilesMatch>
     Deny from all
   </IfModule>
 </DirectoryMatch>
 <Directory "/var/www/html/restapps">
   DirectoryIndex applications.php
 </Directory>
 # restapps
 Listen 135
 <VirtualHost *:135>
   Alias /.well-known /var/www/html/.well-known
   Alias /.freepbx-known /var/www/html/.freepbx-known
   RewriteEngine on
   RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
   RewriteRule (^\.|/\.) - [F]
   DocumentRoot /var/www/html/restapps/
 </VirtualHost>
 # Starting hpro
 <Directory /tftpboot/>
   AllowOverride None
   <IfModule mod_authz_core.c>
     <FilesMatch "(^\.|.php$)">
       Require all denied
     </FilesMatch>
     Require all granted
   </IfModule>
   <IfModule !mod_authz_core.c>
     <FilesMatch "(^\.|.php$)">
       Deny from all
     </FilesMatch>
     Allow from all
   </IfModule>
 </Directory>
 # hpro
 Listen 131
 <VirtualHost *:131>
   Alias /.well-known /var/www/html/.well-known
   Alias /.freepbx-known /var/www/html/.freepbx-known
   RewriteEngine on
   RewriteRule ^/\.(well-known|freepbx-known)/ - [H=text/plain,L]
   RewriteRule (^\.|/\.) - [F]
   DocumentRoot /tftpboot/
 </VirtualHost>
 # Starting leport
 # Skipping leport as it is disabled

(Bob Reiber) #4

I had this problem recently too. The fix for me was to change the ports via the command prompt

in putty get into mysql, then use the asterisk database, then change the lets encrypt port to something other than 80, then change the http port to 80. Once it’s activated you can change the ports back in the sys admin module.

See dicko’s comment at the end of the thread for the proper syntax, the forum strips some of the formatting. The word key needs the single back quote (next to the 1 on the keyboard) around it.