Paging and Intercom Channel Local/[email protected] left softmix base-bridge

Hi,
I have samoe issue about paging and intercom

Server info :
Dualcore Ram 8GB Disk 500GB
I installed SNG7-FPBX-64bit-1707-1
[[email protected] ~]# asterisk -r
Asterisk 14.6.0,
paging and Intercom 13.0.26.1 Stable

Steps I’ve done

  1. Upload Recording mp3 file (3 minute 9 second) and Choose Convert to all format (alaw,g722,gsm,sln,sln16,sln48,ulaw,wav),
    https : //s2.postimg.org/8c23s1h2h/recording.png
  2. And then created Announcement with select recording i have done step 1,
  3. Add Local Networks on Asterisk SIP Settings,
  4. Add Extension using SIP type,
    https : //s2.postimg.org/o0a4wfrd5/extension.png
  5. Created Paging Group
    https : //s1.postimg.org/yp70jy6r3/paging1.png

Client Side :

  1. Ubuntu desktop using Yate softphone,

Testing :

  1. Dial to extesntion number with paging and intercom format *80+extension (Exp : *80803)
    The result : 2 minute play a music and after 2 minute auto hangup
  2. Dial to paging virtual extension (Exp : 699)
    The result : CLI Asterisk logs show : left ‘softmix’ base-bridge in 1 second
    For details logs : https : //s2.postimg.org/x37egoji1/Asterisk-logs.png
    At client side still playing music upto 30 second and after 30 seconds disconnects/auto hangup
    At caller side still active

What should i do to fix it
Any suggestions or advice to troubleshoot is greatly appreciated.

Regards,
Andre

Hi,
Any suggestions or references I can learn to fix?

You are probably experiencing the issue described in this post

1 Like

Hi
Thank you very much for your info,
I have read it and there said it is probable because “RTP session might be timing out”
And I tried to change the value of RTO time out In settings -----> Asterisk SIP Settings
Such as the following, but no effect :

RTP Timeout : 90
RTP Hold Timeout : 300
RTP Keep Alive : 90

Any suggestion ?

You should start by taking a SIP debug trace of the call that fails. If it always fails after 30 seconds, there must be something wrong. Get a SIP debug trace and use it to analyse what is happening at second 30.

1 Like

Hi,
Thank you very much for the suggestion

Here the SIP debug results when i dial to paging virtual extension
https://pastebin.com/UckSd9Ma
I do not understand where the cause

You will need to do some reading in order to understand why the call is being dropped. The sip debug is your starting point. Make sure the sip debug trace covers the call from the begining until it is dropped.

1 Like

Right, I’ve read the SIP debug but there is no information cause hangup/dropped
There is only information joining ‘softmix’ base-bridge and left ‘softmix’ base-bridge but no information on the cause,
or you can point me where the issue from the SIP debug file : https://pastebin.com/UckSd9Ma

Until this time I have not been able to solve this problem, If anyone has any suggestions, can be informed

Here config paging in the file extensions_additional.conf :

[app-page-stream]
include => app-page-stream-custom
exten => s,1,Wait(1)
exten => s,n,Answer
exten => s,n,MeetMe(${PAGE_CONF},${PAGE_CONF_OPTS},)
exten => s,n,Hangup

;–== end of [app-page-stream] ==–;

[ext-paging]
include => ext-paging-custom
exten => 201,1,Goto(app-pagegroups,201,1)
exten => 201,hint,Custom:PAGE201

;–== end of [ext-paging] ==–;

[app-pagegroups]
include => app-pagegroups-custom
exten => 201,1,Macro(user-callerid,)
exten => 201,n,Set(_PAGEGROUP=201)
exten => 201,n(busy-check),GotoIf($[${TRYLOCK(apppagegroups201)}]?:busy)
exten => 201,n(devstate),Set(DEVICE_STATE(Custom:PAGE201)=INUSE)
exten => 201,n,Gosub(app-paging,ssetup,1())
exten => 201,n,Set(PAGEMODE=PAGE)
exten => 201,n,Set(PAGE_MEMBERS=100-101-102)
exten => 201,n,Set(PAGE_CONF_OPTS=1dqsxm)
exten => 201,n,Set(ANNOUNCEMENT=custom/SelepasKauPergi)
exten => 201,n(agi),AGI(page.agi)
exten => 201,n,Answer
exten => 201,n(page),MeetMe(${PAGE_CONF},dqwxAG,)
exten => 201,n,Hangup
exten => 201,n(busy),Set(PAGE${PAGEGROUP}BUSY=TRUE)
exten => 201,n(play-busy),Busy(3)
exten => 201,n(busy-hang),Goto(app-pagegroups,h,1)

exten => h,1,ExecIf($[${ISNULL(${PAGE${PAGEGROUP}BUSY})}]?Set(DEVICE_STATE(Custom:PAGE${PAGEGROUP})=NOT_INUSE))

;–== end of [app-pagegroups] ==–;

Is there anything missing?

I haven’t even looked at the code, but if your exten=>201 code is being entered into extensions_additional.conf, the changes you are making will be overwritten. If this is code out of the Paging module, then you’re fine. If you are managing the 201 paging stuff by hand, you may want to make a couple of minor changes:

Put all of the “exten=>201” into the extensions_custom.conf file and make the following changes:

[ext-paging-custom]
exten => 201,1,Goto(app-pagegroups,201,1)
exten => 201,hint,Custom:PAGE201undefined> ;
–== end of [ext-paging-custom] ==–;

[app-pagegroups-custom]
exten => 201,1,Macro(user-callerid,)

[remove the exten=>h,1 reference - it’s superfluous]

1 Like

Thanks a lot for your suggestion, I will try and info the result

Hi
I have tried but still got same issue, no effect
Logs : https://s26.postimg.org/59ywaoa5l/logspaging.png
extensions_custom.conf file : https://s26.postimg.org/amnqosy21/logspaging2.png

Any suggestion ?