Pager Email Address

Issues with the “Pager Email Address” operations.

Version of FreePBX: freePBX 2.11.0 21 in use with Elastix PBX

What Works:
Ok, setting the “Pager Email Address” within the FreePBX GUI, “Settings”, “Voicemail Admin”, “Settings” I have filled in the “pagerbody”, “pagerfromstring” and “pagersubj” … it works with no issues.

What’s Not Working:
According to previous set-ups I have done in the past one could go to a extension and within the box that says “Pager Email Address” enter the pager number (or cell number), then in the next box change the “VM Context” from “default” to “feature1”, then save, then goto the file “voicemail.conf” and add the "[feature1] context of
pagerbody=The message to be displayed onm the pager \n\n

to the bottom last line of voicemail.conf and by doing this you could have a different message sent when some one left a voicemail for that extension based on the extension number. I have tried to set up different extensions again under this version of FreePBX, and it will not send any message except the one that has been set within the Voicemail Admin pager body section. In other words, it will not send the message that is in the [Feature1] pagerbody. Somewhere something has changed or is there a bug with this code?

Could someone of knowledge of how this pager eamil address works please advise the proper way to set up the ability to send a particular text message based on a particular extension. In other words, I don’t want to send the same text notification to all pagers, I want to assign a different pager notification text for each extension I add to the server. Could someone advise the proper way of doing this…maybe a step-by-step please.

Just to save time, I have already done the forum question in Elastix forum, and the asterisk forum and both communities have suggested that it is a issue with the way freepbx sets up this portion of the pager notification since asterisk doesn’t use the or files…

Thanks in advance,

Adding this infromation… Even with this config:

100 =>
1664,Accueil,,[email protected],attach=no|pagerfromstring=Feature1|pagersubject=Message|pagerbody=Nouveau|saycid=yes|envelope=no

The pager options are not enabled.
A default message is sent instead of the custom pagerbody for this voicemail.

From Asterisk forum, it seems to be caused by the split files and