Outgoing calls routing improperly

Yes, I have used those explanations under the ?. They are what has helped me successfully configure my other 4 systems.

My confusion starts when I try to dial outside my area code. Why is the system inserting the 1909 into my dialing sequence when I am dialing a 626 area code? In doing so, it obviously completely changes the number I am trying to dial. On top of that, it does not happen every time. It may work correctly 10 times in a row, but then, on the 11th try it will insert the 1909 again. It does not do this on any of my other 4 systems which are setup the exact same way.

OK. you are in California, you use AT&T, just assume and use 11 digit dialing, everyone here will then understand 1NXXNXXXXXX, but NXXNXXXXXX and NXXXXXX will need to be handled as special case by AT&T, just don’t do it that way.

Not sure what you are telling me here. Sorry.

AT&T in california should accept dialing 1nxxnxxxxxx if you force this, it will circumvent all your efforts to dial anything that does not begin with 1 if you arrange all your old fashined 7 and 10 digit dialing to use that 11 digit format in your outbound route.

I thought that is what I was doing by adding the 1909 in my trunk configuration. Are you saying I should add this to my outbound route as well to try and force all calls (local AND long distance) to use 11 digits? By the way my provider is Verizon at this location. Not sure if that changes things.

And yet you stated quite firmly ain your post:-

“4 analog lines from AT&T into a digium 4-port card”

make your mind up.

Sorry, that was a mistake. I have 74 locations and I manage the phone systems at all of them. I just got mixed up.

Go to your local CO, ask for a white page directory, read the first few pages, implement what is stated there for your dialing needs.

that is the solution. This system was put in two weeks ago. Prior to that, they were using 4-line AT&T phones. The dialing process has been the same and has not changed - local calls do not require the area code so they only need to dial the 7 digits; long distance calls (outside the area code) require a 1+ the area code (1626 for example). I have setup my outbound route and trunks identical to that of another asterisk system in the same area code with the same provider (Verizon). On top of that, it doesn’t happen with every call.

Why is the system inserting the 1909 when I am dialing and 11-digit number, and why is it doing it randomly? Especially since all the trunks are setup the same way as you can see from my screenshot.

…with my butt-set at the MPOE, I have no problems dialing whatever I want. I can dial my cell phone without fail. I am dialing the exact same digits as I am dialing from the Digium phone. I am sure it is a setting or something is broken. I need help figuring out what is it. Thank you for your time.

It is inserting it because you asked it to, just slow down, read the manual and develop a completely closed dialing plan where there is no room for confusion, if you allow 1nxxnxxxxxx and nxxnxxxxxx and nxxxxxx (as your previous posts suggest) then you need to stop doing that apparently, 1nxxnxxxxxx would be your best solution so you would prepend 1909 to your 7 digits, and god forbid if you allow nxxnxxxxxx, prepend a 1, that is just two rules that should cover everything in NANP land without confusion. If you do not have a closed set of dial rules, then have your users postfix a # or wait the default 5 seconds for asterisk to work out what you want for them.

I still think at least part of the problem is not having the (W)ait for Dialtone. That being said, att requires 10 or 11 digit dialing because of overlay area codes (NPA 601 and 769). Problem is that not all of the NXX’s served by those NPA’s are in the local calling area. For those in the local calling area you don’t dial 1 and for those outside the local calling require 1. I guess I could have created a whole bunch of Dial rules that sorted this out, but I didn’t. In any case, within the 601 and 769 NPA there are both local and toll calls either requiring a one or not.

The other thing I have to ask is whether the Verizon lines are True POTS lines or if they are, in fact, brought to your premise as digital and converted to analog by an ATA. That may behave differently that a true POTS. But then again, I guess there are very few true POTS lines around…A single copper pair for esch number going all the way back to the CO.

Thanks, w5waf. I too am not sure if they are true POTS, but I know that they are single copper pairs from my building to the street.

I have added two w’s to the dialing options on my trunks.

is that the proper syntax? Should I only have 1 w in there?

I have mine in the prepend box, but you could put it in the outbound dial prefix box. There’s no set number you put in, I’m using a single W now, but I’ve had to put in 2 or 3 for some pots lines. It’s trial and error.


OK. I’ll try it out and let you know. Thanks again!

Thanks for all your help dicko and w5waf. I tried everything that was recommended and the things you guys requested to no avail. It was still inconsistent when dialing out.

I implemented a work-around that is working so far (crossing-fingers). As you suggested, I am forcing the users to dial the area code whether it is local or long distance. Like I said, so far so good. I’ll post back if anything changes.

…the issue persists. I have tried everything I can find and all the different settings that I can see to no avail. I am forcing the users to dial 1+area code for all calls including local. It takes several attempts before the call goes through. I am this close to ripping it down and starting from scratch, although not sure what this would accomplish.

Perhaps you need that butt-set (preferably one with a DTMF readout on it) and some patient monitoring again? . . .

I think so. I will post back my findings.

I ordered the buttset with DTMF and while I wait for that to come in I decided to try a couple of things. I have an 8-port FXO card but we are only using 4 of those ports right now. I moved all the telco lines to ports 5-8 instead of 1-4 and dialing worked perfectly…for about 2 minutes. I was able to dial around 8 909 numbers successfully without dialing 1909. But, then it stopped working again. Still SMH