Outgoing calls routing improperly

…so, I have opened a support case with Asterisk in regards to this issue. I performed some captures and submitted them for evaluation. Waiting to hear back from them. I will post when I receive an update.

I have been going back and forth with Digium Support on this issue. I hooked up a Fluke TS53 Pro and saw that in fact only 6 digits were coming through. Digium is telling me this…

 "From the evidence we have so far, I think what we're seeing is a classic    case of the far-end (the test equipment) is begins to 'listen' for the DTMF after Asterisk has already begun sending them.  We can make this assumption since the issue is consistently dropping the first digit.  The dahdi_monitor recording also demonstrates that all of the digits are being sent over the line.

 Normally in this case Asterisk should be delayed before sending the DTMF over the line, giving the far-end long enough to begin 'listening' for the digits.  The most graceful way to handle this is with the  wwwww's  prepended to the front of the digits within the Dial() application.  Since the FreePBX GUI seems to have no option for this though you may need to look into building a custom dialplan section in FreePBX that inserts the  Wait() application just before the Dial() application for these calls.

 Unfortunately this level of troubleshooting is outside our scope of support so I'm unable to give you the best information.  I would recommend reaching out to SchmoozeCom for FreePBX support to help resolve this issue.  As the official sponsor of the FreePBX project, SchmoozeCom can provide the best support for configuring the FreePBX GUI to the degree your issue requires."

I don’t know what to believe at this point. If I were to add more w’s to prepend the number dialed, would I do this here (http://s27.postimg.org/9vny044ir/wwwws.png)?

Please advise

No, not that field. Use the field labeled ‘Outbound Dial Prefix’ a few fields below.

OK. I have input 4 w’s. I will test and post back. Thanks!

Please be aware that there is a bug with entering w’s on the trunks page, The lowercase w’s will turn into uppercase W’s and Asterisk will ignore this. http://issues.freepbx.org/browse/FREEPBX-6318

It shows “resolved”. Has the bug been fixed or is there a work-around?

Does anyone know if this bug was fixed or if there is a work-around?

I ended up removing the 1909 dialing pattern that I had in the trunk settings forcing the user to dial the area code at all times. I also inserted 4 w’s into the trunk settings. This seems to have done the trick. so far so good.