Outgoing calls routing improperly

Hello. I am running Asterisk v11.5.1 with FreePBX 2.11

I am having trouble when dialing out. It is inconsistent at best. I will attempt to dial my cell phone from one of our Digium D40 phones and sometimes it will connect and ring my cell phone and other times I get sent to this other company. I have tried it 20 times and it rings my cell phone 5 times. It rings that other company 14 times And then once it even rang to a fax machine.

My trunks and outgoing route looks fine in the FreePBX GUI and incoming calls work perfectly. I have tried from different phones with the same results. Any help would be greatly appreciated.

Thank you.

Also, after dialing a number and about 20 seconds of dead air, I get the following message on occasion…

“If you’d like to make a call…”

What trunks are you using?

4 analog lines from AT&T into a digium 4-port card

Not sure if this is related to my posted issue, but I am seeing the following errors while logged into the Asterisk CLI…

[2013-10-23 16:33:16] ERROR[19775][C-0000013b]: callerid.c:566 callerid_feed: No start bit found in fsk data.
[2013-10-23 16:33:16] WARNING[19775][C-0000013b]: chan_dahdi.c:1826 my_get_callerid: Failed to decode CallerID
[2013-10-23 16:33:32] WARNING[19775][C-0000013b]: chan_sip.c:21886 func_header_read: This function can only be used on SIP channels.

I would put a butt-set on the lines and make sure what you think you dial is being dialled. You can use a regular single line phone if you get the off-hook timing right, i.e. pick up momentarily after you dial from Asterisk.

Given that, I would retry your calls on a different trunk, and call AT&T repair if the problem is only on one line.

Pot a pause in the trunk so the system waits a second or two before dialing.

So, I put my butt-set on each line and found that line 2 is dead from the MPOE. However, I think this only explains 1 of the errors if I am not mistaken. I think this only resolves the issue in my 2nd post which gave me the “If you’d like to make a call…” message. Please advise.

AS Alan said add a pause is your bellcore FSK bitch on an incoming or outgoing call?

How do I add the pause? I do not see that option on my outging route nor my trunks

Outbound Trunk Dial options, add a Dw for 0.5 second pause, D for dial w for wait.

Strange. I made the change in “Asterisk Trunk Dial Options” to override and put the ‘w’ in there. I then made 10 calls in a row that went through just fine. Then I dialed one last time and I got that exact same wrong number again. I have tried dozens of calls from the butt-set at the 66 blocks and each of them have dialed correctly, so I’m sure it’s something in Asterisk.

Crap. I think I see what’s happening but not sure where to fix it. The number I am dialing from the phone is 626-331-7590 and the people that keep answering finally gave me their number which is 909-626-3317. I am dialing from the 909 area code. So… it looks like Asterisk is stripping away the area code. The strange thing is that it is hit and miss. Why is that?

Scratch that. It seems that Asterisk is inserting the 909 area code before the number I actually dial

What do your outbound routes look like? Is there anything in the prepend or prefix fields that night be changing the digits? It is not uncommon to have a rule that takes a 7 digit number and add the local area code. For example I have a dial pattern that matches NXXXXXX and prepends my local area code. You can also have rules that match a pattern and modify it.

Put a couple of additional waits in…


I think you will find that the California PUC has required that you can dial within 909 WITH the 909 area code. I suggest that you prepend that for all 7 digit calls.

…of my outgbound route

…of my trunk ( this is just one of four that are configured the same way)

Please advise as to what I should change. I have 4 other systems that are setup pretty much identical to this one. Curious why this one doesn’t work as the others do. Thank you!

Whether it’s correct or not depends on what you are trying to do. In your trunk setting, you’re stripping the 1909 if 1909 is received and just sending along the seven digit.

I’ve seldom seen a pots line used as a trunk consistantly without at least 1 wait (W). This would be entered as a “W” in the prepend box.

Have you rolled your mouse ofve the little green “?” on near the boxes? It explains all of this rather well.