Outgoing calls and getting "The number is not answering" message

I am new at this, but have been working on this program or about 4 weeks now. I am using Free PBX.

I have extension to extension working fine, I have paging working fine, I have IVR working fine and I am getting incoming calls fine.

This is the problem, When I make a out going call. I will dial the number and hit send, the audio goes blank (as if it goes dead) for about 20 seconds then I get a recording saying “The number is not answering” then I get a busy signal. I am calling my cell phone and it is not ringing, I have also tried other number and still the same thing.

I have worked on this for two or three days now, and did plenty of research and could not find anyone else having this problem. I hope some one out there will be able to give me some suggestions. I am so close not to have a operating system.

I still have the “Could not reload the FOP server” Error, but I can use the fop module. Would this have any thing to do with it?

Thanks for any help,
Daniel Bo

look at /var/log/asterisk/full after you make your call. If you don’t do Linux you can get the last lines under Reports/Asterisk Log Files

That should tell you something. You may have a NATing issue. I’m sure you have an Outbound Route set up that points to a Trunk?

Are you SIP or IAX?

I did this: But I am really not understanding it. I am hoping someone would look at this and tell me something. PLEASE and Thank you.

[2012-11-08 00:57:56] VERBOSE[6079][C-00000004] app_dial.c: – Called SIP/Vonage3/3049912616
[2012-11-08 00:58:28] WARNING[1681] chan_sip.c: Retransmission timeout reached on transmission [email protected] for seqno 102 (Critical Request) – See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 31999ms with no response
[2012-11-08 00:58:28] WARNING[1681] chan_sip.c: Hanging up call [email protected] - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] app_dial.c: == Everyone is busy/congested at this time (1:0/0/1)
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s@macro-dialout-trunk:23] NoOp(“SIP/400-00000008”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 18”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s@macro-dialout-trunk:24] Goto(“SIP/400-00000008”, “s-CHANUNAVAIL,1”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-CHANUNAVAIL@macro-dialout-trunk:1] Set(“SIP/400-00000008”, “RC=18”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-CHANUNAVAIL@macro-dialout-trunk:2] Goto(“SIP/400-00000008”, “18,1”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Goto (macro-dialout-trunk,18,1)
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [18@macro-dialout-trunk:1] Goto(“SIP/400-00000008”, “s-NOANSWER,1”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Goto (macro-dialout-trunk,s-NOANSWER,1)
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-NOANSWER@macro-dialout-trunk:1] NoOp(“SIP/400-00000008”, “Dial failed due to trunk reporting NOANSWER - giving up”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-NOANSWER@macro-dialout-trunk:2] Progress(“SIP/400-00000008”, “”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-NOANSWER@macro-dialout-trunk:3] Playback(“SIP/400-00000008”, “number-not-answering,noanswer”) in new stack
[2012-11-08 00:58:28] VERBOSE[6079][C-00000004] file.c: – <SIP/400-00000008> Playing ‘number-not-answering.ulaw’ (language ‘en’)
[2012-11-08 00:58:29] VERBOSE[6079][C-00000004] pbx.c: – Executing [s-NOANSWER@macro-dialout-trunk:4] Congestion(“SIP/400-00000008”, “20”) in new stack
[2012-11-08 00:58:29] WARNING[6079][C-00000004] channel.c: Prodding channel ‘SIP/400-00000008’ failed
[2012-11-08 00:58:29] VERBOSE[6079][C-00000004] app_macro.c: == Spawn extension (macro-dialout-trunk, s-NOANSWER, 4) exited non-zero on ‘SIP/400-00000008’ in macro ‘dialout-trunk’
[2012-11-08 00:58:29] VERBOSE[6079][C-00000004] pbx.c: == Spawn extension (from-internal, 3049912616, 6) exited non-zero on ‘SIP/400-00000008’
[2012-11-08 00:58:29] VERBOSE[6079][C-00000004] pbx.c: – Executing [h@from-internal:1] Hangup(“SIP/400-00000008”, “”) in new stack
[2012-11-08 00:58:29] VERBOSE[6079][C-00000004] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/400-00000008’

I don’t know anything about Vonage SIP trunks. Clearly you have something wrong. Asterisk sent a message to Vonage and they did not respond in 30 seconds so the system gave up, the rest is just noise:

[email protected] for seqno 102 (Critical Request) – See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 31999ms with no response
[2012-11-08 00:58:28] WARNING[1681] chan_sip.c: Hanging up call

I have read the article on the web page that the error message suggested.

They suggest a problem with the nat and invite, plus explained what was going on. I looked at the set up for nat in the extension setup and in the Trunk setup in FreePBX. I also looked on the phone itself setup and found that all three of the setups are different.

Some says nat=yes, some say nat=no, didnt seem like any of the three matched. I made all of them say yes. What would you say they all should say?

Then I have the invite, those to were all three different. But my question is, that I couldn’t understand from the article, is what should they all be. Or am I completely off track in making them all match?

You have not told us much about your system:

Need -

Asterisk and FreePBX version
How they were installed (Distro or by hand)
If Distro, which one and version
Description of network topology
If any phones not on the same server need description of network at remote location.
Trunk config (redact private info).

I am using Distro 1.1100.211.63
If I am understanding it right it is astrisk FreePBX
I installed it from cd disk with Distro
All the phone are local, nothing remote.
qualify=in sip.conf

User Details
fromuser=[vonage phone number]

Register String
1304xxxxxxx:[email protected]:5061

As I mentioned I have the page feature working, plus incoming calls. It is just the out going calls. When you dial the number you get dead air for a few minutes then a recording comes on and says “the caller is not answering” and then I get a busy signal, then disconnects.

I am calling my cell phone and it is not ringing.

Thank you for any help, this is the last step I need to do.

Vonage is using port 5061. how are you accounting for that in your router? You will need to forward 5061 UDP to the LAN address of your server. Hopefully that is set to a static address. Then you will need to look at your Settings/Asterisk SIP settings an make sure your Static IP info is set properly and that you fill in the Local Network info.

Thank you franklin,
This is what I have done so far. I went into the router and set port forwarding to the PBX server which is and set the ports tcp and UDP to 5061.

I have gone to settings/asterisk sip settings and made the external IP to danielbo.selfip.com:5061 and it is set at static.

Local networks I have two listed which is the ip to the router and which is the IP to the server.

Now here is a question. I had the NAT some setting was set to yes and some to no. I made them all yes. The reinvite was the same, I made them all yes also.

I have non standard G726 set to yes and T38 pass through set to yes.

Does that sound right so far? Thanks for your fast reply and help.


are not valid networks


Hello Dicko,
Why are they not local networks? I must be thinking wrong because that is what I would thought would be my local network.

How about the rest of the setup. How does that look?

Then I am unsure of nat and invite?

What would you suggest it would be? I must be lost.

I have everything working now. I have all the IVR’s working, (but the ones that make a out going call.
All the menu are set up. It is taking faxes, the intercom, phone to phone call, voice mail, just as far as I know I have everything working perfect.

Its just the outgoing calls. I am looking for someone out there that uses Vonage, that might be able to give me some setup idea. I have almost all my information listed about on how I have it set up now.

The problem is when I call out, it sounds dead, but then a message pops in and say the “phone is not answering”. The phone it is calling is not ringing either.

So excited I have made it this far. Just one more step and I will have it, other then I still have the FOB error showing, but some of those things can be worked on afterwards. Thanks all for you help. I am still learning.

danielbo.selfip.com:5061 seems an odd form to put in you Static IP field. I would pud just the IP or the DNS. But not the port, because that is defined elsewhere. As a matter of fact, you may need to set that in Advanced settings. I forget. Not sure if a DNS address is accepted here. You do have something wrong somewhere. If everythign else is working, this is a bugger. Do you have a static IP from your ISP or dynamic? Look at your Admin/System Admin/Network Settings and make sure those are correct and that you have your Gateway set as the router’s address, I’m assuming

I have made those changes, going to look around to see if I have it any where else.

Do have a static IP address, that is why I thought using danielbo.selpip.com would be better because in case it changes. But was wrong.

And my Gateway is I will be checking that all is fine there.

But before I start looking at everything would you have any idea if my NAT should be set to yes or now?

Then there is the invite, I believe it as many choices, but should it be yes or no.

I have no clue on NAT or Invite. I really have no clue on most of it, but learning. I have done research on them, just not catching on about it.

Thanks so much for your help.

E ones at the top and bottom T externip that expects a dotted quad.

You know there are like 8000 documents on NAT and Asterisk, it would help you much if you reviewed one.

If you want to specify a dynamic outside IP you must use a the externhost field not externip that expects a dotted quad. Don’t forget to set the externrefresh timer.

Lastly, and I am being stern here because you don’t seem to be listening. As Dicko said you must specify a network address instead of two ip’s in the same network as you have. A network address is the first address in the group as defined by the subnet mask. In your case you used a 24 bit mask (8+*8+8). That gives you 8 bits of addresses, 256 of them. 0-255 so the bottom is the network address and the top is the broadcast. A network address is shorthand for the entire addressable network. I am sure you can find a more cogent explanation of IP networking on the net. It never fails to amaze me that folks who do networking don’t understand the purpose of a subnet mask.

I hope this helps and gets that audio working for you.

Oh you only want NAT on in the trunk and remember the localnet is the addresses excluded fro NAT processing. Remember your phones on the same network do not require NAT.

should be no. Try NAT no on your extensions. You may want to invest $129 for an hour of support. It may save you a ton of time to just have someone look inside the box for you.

I have looked though out the board and have read plenty. But you know what I read the most of, is your ruddiness. Do you ever say anything nice? I have not read one reply without you saying something hateful to someone. Why are you that way, do you hate the world?

I do listen to everything you say after I get past all your hatefulness. I believe you know what you are talking about and I appreciate your help.

I just can not for the life of me understand why you are so hateful. Smile and try to be nice just one time. If you dont like it one here, why do you get on here. I do appreciate your help, but not your sarcasm.

I would like to meet you, and since you have given me help, I would give you some help on being nice to people.

Thank you

I have said it 1000 times I am sarcastic not rude.

If you ever met me you would see I am the opposite of what you describe, I hate no one and am always laughing.

I was chuckling at that message when I typed it. Dicko told you exactly what to do and you argued with a network engineer and dismissed what he said about network addresses, I took the time to explain it to you so maybe on the off chance that you will be one of the few that “get ot”.

How can you not be a bit sarcastic when you have type the same instructions on NAT 1000 times and folks still say they can’t find any info.

If you want to help me communicate the information more effectively tell me how you could read as extensively as you indicated yet still think a URl with a colon and a port number belongs in an IP field. Heck the tool tip covers that.

Lighten up, we are all here to help.

Sorry if you took offense at my style, none intended.

If he and you thought I was arguing with him, I am really sorry. I was not meaning to. I was just explaining what and why I did what I did. So I hope he doesnt think I didnt appreciate his help. Believe me I really appreciate all of you. Even SkykingOH, no matter how mean he is to me, he is great help.

I didnt dismiss what dicko said, I did exactly what he told me to do, and I do the same to everyone’s suggestions. I have no idea on what I am doing, so I have no right to argue with anyone. So Dicko, if you thought this, I am truly sorry. I was happy he set me straight.

I have done both, I first just set the NAT on the phone to no, then I did it also on the extension set up. No luck

Next I have tried the invite, set it to as needed on the phone, and tried it, then set it to no-rc (something) on the extension set up and still no luck.

I will try what ever I anyone says, and believe me, I would never under estimate what someone tells me. I might explain why I did what I did, but I am still going to change it.

Its just crazy to me, that incoming call are great, but out going is not doing nothing. It has to be something little. As I mentioned a while back we are a small company, we help people that really cant afford a apartment,get one so they are not living on the street. So for us to fork out $129.00 for a hour of help is really tuff on us. I am retired and just do this to help others. So I rely on you guys for help. It might just be dealing with vonage, but 3cx worked fine, Vonage is cheap too.

So I am still open for suggestions. I have even rebooted every thing, hoping that would work. Nope.

Well again not being rude just direct and always with a little sarcasm, don’t take it personal it never is.

Just because it’s free there is a huge learning curve and even seasoned IT vets have trouble. IP telephony requires knowledge of telephony, expert level network skills and occasionally good Linux sysadmin experience. Asterisk is also full of quirks that much experience become intuitive.

This has been a painful thread, you didn’t answer my question about how previous NAT info was vague or incomplete. If you are entering parameters without knowledge of what they do I can’t imagine how hard it must be.

Vonage is not all that cheap and I don’t know anyone running them so none of us have any practical experience. If budget is key I can’t imagine that one of the penny a minute pay as you go carriers would not be the most budget friendly.

I don’t know why you outbound is not working, however to show you I am not an ass since you are a non-profit I might be able to pop in your system over the weekend and see if I can’t get you on track, it certainly will be easier than this trial and error method.