FreePBX | Register | Issues | Wiki | Portal | Support

Outbound CID shows additional digits on Android phone


#1

I’ve been using FreePBX for my SOHO since 2014 and I’m very happy with it.
Just upgraded from FreePBX 2.11 to 14.0. (I know…a big leap but if it isn’t broken why mess with it!)
The main reason I even upgraded was I am moving from bare-metal machines to virtual-machines.

Have been using FlowRoute as my SIP provider since the beginning. Simple, no frills and low cost.

I use the trick of pre-pending digits based on the extension in order to set the outbound CID. That way calls from a office phone have the office CID and from a home phone have the home CID.

This was what I used on my old system and I ported that into the new system. I didn’t look to see if there was a better way now.

Now, when I call my Android cell prone (Galaxy S6) I see an additional 9 digits appended to the caller ID
These additional digits are not the same every time but they are similar.
Oddly, they do not appear on my IOS phone. (I suspect Apple my be filtering or suppressing them?)

In both cases, the calling phone number is in the contact list of the phone.

On the Android phone, while the phone is ringing the CID simply has an extra 9 digits
(e.g. where “7605551212” is the true number I will see “7605551212761213663” )
If I end the call without the cell phone picking up,
the “missed call” on the lock screen shows “7605551212;rn=+1323496” (examples drawn from different tests)

Looking at the asterisk logs I find no reference to these additional characters or digits at all.

Google (who is normally my friend) was no help to me at all. I have not yet reviewed the logs at FlowRoute.

  1. Is this really a problem or just an artifact?
  2. If a problem, where could it be creeping in?

Any thoughts, input or suggestions are welcomed.

Thanks,


#2

The straightforward way is to set the Outbound CID field for the extension to e.g.
"Event Horizons" <17605551212>
and if you don’t override this in your Outbound Route or Trunk settings, it should pass through to the trunk.

Note the initial 1. If you try to send without it, the initial 7 looks like the country code for Russia but there aren’t enough digits and some intermediate system could be rewriting it.


#3

The following is all based on what I had in my old FreePBX build. (IIRC, for some reason that method did not work back then.) I am by no means an Asterisk expert. I google and I read. A lot!

In “extensions_custom.conf” I had set up a “[from-ext1111]” that added “00111” to the number being dialed and this was entered in the “context” field of the extension…
This then allowed me to select an outbound route based on the added digits and then the outbound route set the CID.

Just now I restored that context to “from-internal” and added the CID to the extension and created a new outbound route that did not override the CID. When I made a test call, the result was the same…main CID was there but with extra digits at the end.

So I can now use this method to set CID instead of the handstands I was doing before and will really only need a single outbound route.

A review of the FlowRoute logs didn’t yield anything useful, i.e. the extra digits do not show there.

Some further testing identified that the issue may be an App on my phone…“Hiya”. I was mistaken when I said the number was in my contact list. It actually is not. The Hiya CID display was the one showing additional digits and now I am not sure that it didn’t do that before because the only reason for me to call my own phone from my office is to test things. I only installed Hiya recently in an attempt to deal with spam callers.

I will do some more testing this evening with the old FreePBX installation to back-check this item.


#4

The problem exists on the old FreePBX build as well so it is most definitely an issue with the “Hiya” app.

I will bring it to their attention. If anything comes of it I will post it here just in case someone encounters something similar.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.