OBI110 SIP Trunk Configuration Help

I’ve got an old OBI 110 that I have connect to a POTS line. It’s working and I’m decommissioning my VERY old FreePBX system. Again, the key here is that I know it works, because I’ve tested with my old system. I just built a new FPBX box (v16.x) and am trying to configure a SIP trunk with the OBI110. I’m not sure PJSIP will work, so I have both enabled on my system (PJSIP and SIP) and have configured the trunk as a SIP trunk. I’m not seeing any outbound or inbound call traffic when I test, which makes me think I have a registration issue. If I try to force a call out on that trunk by removing all other trunk options for the extension, I can see the attempt in the logs, but I’m not seeing errors. I get a fast busy through the phone.

Any advice on where to look or what logs / configs to post? Below are my outgoing SIP settings from the trunk:
host=192.168.1.14
username=spa3000
type=friend
secret=xxxxxx
qualify=no
dtmfmode=rfc2833
disallow=all
defaultuser=SPA3000
context=from-trunk
canreinvite=no
allow=ulaw

Full log, verbosity at least 3, and with “sip set debug on” active.

You have configured for both way authentication. Did you mean to do that?

There are various copy and paste type errors in your sip.conf, that shouldn’t cause a problem, unless your secret is compromised. However, I would suggest forgetting chan_sip. It is very unlikely that there will be any particular problem with chan_pjsip.

Remember that chan_sip and chan_pjsip can’t both have the same port, and as this seems to be an IP based (registration free) system, the OBI needs to be configured with the correct port number for Asterisk.

OK - I’ve deleted the sip trunk and turned off chan_sip in my system for now. Set back to PJSIP only.

Created the new trunk as PJSIP

“Full log, verbosity at least 3, and with “sip set debug on” active.” - Where do I turn this on? In the old days I could do that in a terminal and just watch - but that feature is deprecated (last I tried).

“You have configured for both way authentication. Did you mean to do that?” - I need t receive (into Asterisk) calls from the OBI as well as make them. If I don’t need to auth both ways for that then I don’t need it - but not sure it will work without auth. That’s why I have it enabled.

You normally have to go out of your way for both way authentication with local equipment and ITSPs generally do not support it at all, insisting on outgoing authentication only. Typically. relative to the PABX, phones are incoming authentication only, and FreePBX insists on that, and providers are outgoing only. Typically you would want an FXO gateway to have outgoing authentication relative to the PABX, for toll fraud prevention purposes.

OK - I found the verbose logging setting (currently at 4 - no lower number options other than “on”) and have enabled that. I have auth set to outbound. and registration set to send. This is what I’m seeing in the logs. Looks like the OBI is just not responding to registration:

57456 [2024-03-24 13:12:58] WARNING[23280] res_pjsip_outbound_registration.c: No response received from ‘sip:192.168.1.14:5060’ on registration attempt to ‘sip:[email protected]:5060’, retrying in ‘60’

The registration isn’t reaching the OBI, or the OBI’s response isn’t reaching Asterisk. You should get a response, even if the OBI isn’t expecting Asterisk to register. You need to find where in your network it is getting lost.

If you have the logging correct, you should also see the full text of the REGISTER request, and its re transmissions.

One of these threads may help:

In any case, note that the OBi is not a SIP registrar so you must use
Registration: Receive
To get inbound caller ID working, because the OBi can only send it in the From header, you must also have
Authentication: Both
and
Match Inbound Authentication: Auth Username

If you still have trouble, paste logs (with pjsip logger turned on)

Thanks guys. I’m struggling with how to view registration activity in FPBX. How can I view / watch this?

OK - got the OBI registered with FPBX. Progress. It was needing trunk authentication set to "both and registration set to “receive” on the PJSIP trunk.

Now - neither inbound or outbound calls work from the OBI to the FPBX. I think this means the OBI needs to bridge the PSTN side to the SIP side. I had that working before I started with the new FPBX but have changed so many setting I think I probably broke something. Any suggestion on where to look next?

Check the Line port status for at least 20 volts tip-ring. If not, something is wrong with the physical connection.

Check InboundCallRoute for both Line port and the SPx in question.

If you still have trouble, turn on pjsip logger, paste the Asterisk log for a failing call at pastebin.com and post the link here.

OK - Got it working. The last step was in the OBI - getting the “X_ServProvProfile” set to the correct value (A). Thanks for the help everyone!