Now I'm fairly ticked off about the Commercial Modules

When I had the OSS Endpoint Manager, all I couldn’t do was create custom templates with different config files.

After I uninstalled that and bought the commercial EPM I apparently set a bomb off in our system.

I can’t rebuild config files for the phones because of errors in the program -and- now I come to find out that every phone in the system is rebooting and trying to upgrade firmware (8 times so far today)

As I understand the web site - my choices are to buy paid support to make the EPM stop rebooting my phones or remove the EPM put in the OSS EPM and just limp along.

First, did you remove the OSS EPM and clear tftpboot directory then reprovision all the phones in the commercial EPM?

There is no data migration path between them.

Since you did not tell us what kind of phones and why they are rebooting I can’t help you with that.

I removed OSS and Cleared the TFTPBOOT directory.
Then I lost all the MAC data in “extensions” so I reloaded from a csv file.

This put me - I assumed. Back where I was. So I SAVED configuration, then I checked one phone and REBUILD CONFIG and that is what started the problems. The process fails, so I went no further.

Cisco SPA504G phones. They in fact may BE the problem… since the problems I had with the OSS product were centered on the Cisco phones. Apparently other people have the same problem, yet making custom templates for Astra and others is not a problem.

If I’d bought Polycom or Digum or Astra phones apparently everything works out of the box.

If you are running into memory errors, edit /etc/php.ini and look for:

memory_limit =

If it is @ 128M make it 256M, save it and issue the ‘service httpd restart’ command and see if EPM is working better for you.

I am more then happy to help you here if you can give us details on what is happening and whats going on. I understand you are frustrated but I am here to help. It really does sound like a phone issue if both EPMs have not worked but maybe its just a coincidence.

1- What exactly are you trying to do?
2- What is the exact problem and steps to re-create.
3- What firmware are the phones on and what firmware are you trying to move to?
4- What version of EPM do you have?

Hi - It’s me (dbdataplus) – {see below}

We fumbled around (mostly in the blind) with some issues and things are finally back on track a bit.

First, we HAD cleared the tftpboot directory after uninstalling OSS and before installing EPM. To make the phones stop rebooting we disabled the tftp daemon.

Then we upsized the PHP script size – then someone found that between the uninstall of OSS and the install of EPM the time had been changed because the time zone had reset to GMT.

Fixed all that and re-enabled tftp and we were able to begin to reconstruct the EPM data base.
it just started working on it’s own (I never discount possibilities like that)

That’s all for here. I’ll ask my questions back in the other thread.

**** I had some login challenges this morning. The new login keeps saying that me email is already in use - by me.

I moved 4 posts to a new topic: [Moved] Forum Login issues

To keep this thread on task I moved the login stuff to a different thread.

Sweet. Now let’s resolve your EPM issues. Thanks for dealing with the headaches

Hi Tony – yeah we have a lot of overlapping threads here.
By all accounts over at PIAF the OSS works great with many phones but does not work well -at-all with the Cisco SPA phones. If I edit the base files (model.cfg and spamac.xml) there are no problems… but if generate custom files to cover other configurations the program gets confused and none of the phones download properly. Several people both on and off the board confirmed that the problem was with the combination of OSS and Cisco-SPA and they said to buy the commercial EPM, which I have.

Now getting past the installation problems, which I covered earlier, what I am trying to do is create 4 templates for 4 separate departments so that if a phone fails while I am occupied, they can go to EPM, change mac addresses and get back to complaining about being over worked and under paid.

default config - 4 lines, NO DND button with xfr and bxfr available on the softkey first screen
2ext - 3 main lines with button 4 a separate extension
2Slnt - 3 main lines with button 4 a separate extension “no ring” (silent ring)
3ext - 2 main lines with buttons 3 & 4 for separate extensions

If I understand what’s you’ve written so far I’ve got the line -to- account associations down … just no clue how to relegate dnd to a 2nd or 3rd menu, how to set no ring on an extension.

Yes you are all correct on the account and line stuff. Sorry it may not seem obvious at times but we are trying to be agnostic and let you manage 275 different devices.

As far as the DND I dont think we do anything for softkeys on those phones which would mean you would need to handle that in the base file editor as its a default settings.

Happy to – the basefile editor seems to be a mystery – nothing I understand about soft keys is shown via the basefile editor. I’m getting the IDEA that if I made a file in some format and placed that filename in the “softkeyfile” field of the baseline editor and then checked the appropriate check boxes that file might then be included…

but that’s just a guess. We’ve just about reached the end of our learn-by-doing allotted time. I just opened a ticket w/Schmooze to quote on getting this DONE – then we’ll learn by seeing it work :smile:

Hey don’t feel bad. We engage Schmooze all the time when we are against deadlines.

OK I will talk with support. I just looked and we don’t set anything in basefile for those buttons so those would be defaults Cisco uses. Meaning it would take someone figuring out what config file options have to be defined to remove that and something support wont know off the top of their head as its not something commonly done.

The same is true with no ring. Not even sure that is possible in Cisco to do.

Yes – both are supported by Cisco.
They are just inside the xml files

BUT — that said — I’m going to infer it’s too far off the beaten path for you… at least not in the time-span I have.

We can revert to the OSS product and deploy … it just means some manual editing for me should a phone go down.

I think you are missing the point. Basefile is what writes out the xml files. All you need to do is add it to basefile if you know the option and it will include it in your xml file per phone.

No - I am getting the point.
And I’ll mention to you that I see the modularity in the structure as well. I can see how all the pieces fall into place in the big picture. The concept is actually clever
— That said, without knowing what field on what screen should be filled out in or how it’s not possible to edit I would the spamac file in OSS.

Take for example – the field in the SPA file {bracket}dial_tone group>{end_bracket} - I don’t need to change that from $dial_tone … but if I did – I’d need a far deeper understanding of how the pieces fit than is available via the documentation.

All things in time…

Off on a tangent – something you CAN do – and please do – as soon as you can – in the extension mapping. “save” should have an OPTION CHECK to “rebuild configs” and also to “reboot phones”

In the process of working with it — scrolling down the screens and checking the phone I just edited and then “save” then having to scroll AGAIN and check the same phone and the scroll down and “rebuild” then having to scroll AGAIN and check the same phone and scroll down and “reboot” — is quite tedious.

save --> rebuild --> reboot are sequential actions that I suspect are used at least as much in series as they ever are independently. That is the single area in which OSS got it right.

Anyway – I’m still learning. More to come.

We ran into a related problem with Cisco SPA508G phones restarting due to firmware changes. These were brand new phones but they come with an old firmware version. It’s not possible to update directly to recent firmware from the old version. I manually downloaded firmware to the server and pointed the phones to it. Once they were on 7.5.2b they quit restarting and the newer firmware updates applied.