Not receiving incoming calls from Flowroute

Have had a local FreePBX server ( running for a few months. This afternoon I am not able to receive incoming calls. My SIP provider is Flowroute. I can call out with no issue. When I call in, nothing happens. I have no logs to post because the call isn’t even reaching my server. When I log into the CLI, it shows an active registration with Flowroute. On Flowroute’s call stat page my failed calls are due to “no trunk/registration”. There is another page on Flowroute’s site that shows an active registration, but its 30 minutes old.

Everything worked fine yesterday. I might have accidentally turned a breaker off today, killing power to the server. Not sure about that though. How do I diagnose this? I really need to get this working again.

Sounds like you need to reach out to Flowroute support to see why their infrastructure believes there is no registration when you feel like there is.

In the Flowroute portal, look at the DIDs and Interconnect pages. Possibly, you are routing the DID to a different registration or an Inbound Route that isn’t reaching your PBX. Try setting Expiration for your pjsip trunk to something short, e.g. 120 seconds, Submit and Apply Config, then recheck the status page after a couple of minutes and confirm that the registration is recent.

I know I said earlier there were no logs. This morning I set the verbosity to 5 and I was able to generate log entries when I called the PBX from my cell phone. (The ip addresses starting with 34 are Flowroute’s) What does the following mean:

[2023-07-28 11:28:42] SECURITY[2830]: res_security_log.c:114 security_event_stasis_cb: SecurityEvent=“SuccessfulAuth”,EventTV=“2023-07-28T11:28:42.147-0500”,Severity=“Informational”,Service=“AMI”,EventVersion=“1”,AccountID=“admin”,SessionID=“0x7fb5fc03bc20”,LocalAddress=“IPV4/TCP/”,RemoteAddress=“IPV4/TCP/”,UsingPassword=“0”,SessionTV=“2023-07-28T11:28:42.147-0500”
[2023-07-28 11:28:43] SECURITY[2830]: res_security_log.c:114 security_event_stasis_cb: SecurityEvent=“ChallengeSent”,EventTV=“2023-07-28T11:28:43.501-0500”,Severity=“Informational”,Service=“PJSIP”,EventVersion=“1”,AccountID=“”,SessionID="[email protected]",LocalAddress=“IPV4/UDP/”,RemoteAddress=“IPV4/UDP/”,Challenge=“”
[2023-07-28 11:28:43] SECURITY[2830]: res_security_log.c:114 security_event_stasis_cb: SecurityEvent=“ChallengeSent”,EventTV=“2023-07-28T11:28:43.590-0500”,Severity=“Informational”,Service=“PJSIP”,EventVersion=“1”,AccountID=“”,SessionID="[email protected]",LocalAddress=“IPV4/UDP/”,RemoteAddress=“IPV4/UDP/”,Challenge=“”
[2023-07-28 11:28:43] SECURITY[2830]: res_security_log.c:114 security_event_stasis_cb: SecurityEvent=“ChallengeSent”,EventTV=“2023-07-28T11:28:43.669-0500”,Severity=“Informational”,Service=“PJSIP”,EventVersion=“1”,AccountID=“”,SessionID="[email protected]",LocalAddress=“IPV4/UDP/”,RemoteAddress=“IPV4/UDP/”,Challenge=“”
[2023-07-28 11:28:43] SECURITY[2830]: res_security_log.c:114 security_event_stasis_cb: SecurityEvent=“ChallengeSent”,EventTV=“2023-07-28T11:28:43.755-0500”,Severity=“Informational”,Service=“PJSIP”,EventVersion=“1”,AccountID=“”,SessionID="[email protected]",LocalAddress=“IPV4/UDP/”,RemoteAddress=“IPV4/UDP/”,Challenge=“”

In your pjsip trunk, Advanced tab, set Match (Permit) to,

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
attempt to call in, paste the Asterisk log for the call at and post the link here.

My outgoing number is the 402-671-2234, destination number is 402-973-9400. I might have copied too much, so scroll down a bit. Thank you again for looking.
Here is the link:

Very strange; pjsip is sending a 401 response to every incoming INVITE. At the Asterisk command prompt, type
pjsip show identifies
and post the output.

It says no objects found

Even stranger. What is the content of

What Flowroute and other pjsip trunks do you have on your system? What chan_sip trunks, if any?

I just have two PJSIP trunks on my system. Both pointing to Flowroute. Here is the content of pjsip.identify.conf:



I don’t know what is actually acceptable, but the tool tip for Match (Permit) does not show the syntax you are using.

Please try:
for Flowroute and
for Flowroute_West_Coast

So I did what you said. It works now. Thank you!

But here’s the big question, why did it work for all those years (configured that trunk in 2019) with the syntax wrong? I can confirm the whole thing started yesterday after I accidentally tripped the breaker off that supplied that server. It was an improper shutdown.

Do you think I should just wipe it clean and start over? It takes a long time for asterisk to load up now when I reboot the server and I sometimes get this weird SQL server screen. Is there a way to do a diagnostic on the server? like a scandisk?

thanks again!

dmesg logs the last boot sequence , the first column is seconds since boot so what is taking a while is apparent, errors and warnings should be heeded. cross referencing with /var/log/syslog sometimes reveals more.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.