No such command file convert in freepbx on centos 6

Hi all
i installed freepbx 13 on centos 6

When i try to upload 1 file wav for music on old i receive this error message:

No such command ‘file convert /var/spool/asterisk/tmp/tmp.1473531008318.wav16/var/spool/asterisk/tmp/tmp.1473531008318.ulaw’ (type ‘core help show file convert’ for other possible commands)

How i can solve it?
Thank you

That ‘file convert’ is part of Asterisk. It means your asterisk binary is corrupt, somehow. I assume you’re not using FreePBX Distro, so you’ll need to recompile Asterisk yourself.

hi xrobau
i follow all the steps on the wiki in this link

this is or not freepbx distro?

now i tried to recompile asterisk follow the same guide on wiki… but if i try to upload my file i receive the same error… :frowning:

Have you confirmed that the command ‘file convert’ does not work in the asterisk CLI? (asterisk -rvvv and then 'file convert … whatever they were … ’ at the asterisk prompt)

If that doesn’t work, then there’s something wrong with the compilation instructions. Have a look through the menuselect options and see if something is being turned off, or is unavailable, because it’s missing a prerequisite?

I last ran through that a couple of months a go with a basic install of CentOS 6. If you’re installing it a different way, there may be something that’s missing that was there when I ran through it.

if i launch the command asterisk -rvvv
i receive this message:
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

if i go in the folder /var/run/asterisk i have 0 file inside…
i don’t undestand how is possible.

what i have to do?
thank you