No Ringback on Some Outbound Calls


(Ryan) #1

I’ve just set up SIPSTATION on my freepbx system and I am able to send and receive calls. I don’t have any prefixes setup and I am able to just dial the number which ultimately connects whoever I’m calling; in this case my cell phone. The issue I am having is that after I dial my outgoing number (my cell phone), I just hear silence. There is no tone as the phone connects to the outside, just silence. Hopefully what I am saying makes sense. Thank you.


(Jared Busch) #2

You have something misconfigured and it is taking an extra long time to connect to your provider.


(Ryan) #3

I don’t doubt that I have something configured wrong. It probably is silent for about 5 seconds and then my cell phone will start ringing. The thing is that it is STILL silent as my cell phone is ringing.I’m not sure where to begin as to what settings I should look at.


#4

Confirm that in Asterisk SIP Settings, External Address and Local Networks are correctly set. If you change these, restart (not just reload) Asterisk.

If your PBX is behind a NAT, confirm that the router is forwarding the RTP port range (default is UDP 10000-20000) to the PBX.

If the above does not help, please post:

Cloud or on site? If cloud, platform? If on-site, virtual or physical? If virtual, confirm that bridged networking is used. Router/firewall make/model?

Do calls between extensions have normal audio? On an outbound call to your cell phone, can the cell phone user hear the FreePBX user?


(Ryan) #5

They are correct.

I believe this is set correctly but I am going through and double checking.

Hosted on-site on a virtual machine. The VM which hosts the pbx has its own ethernet port assigned to it with a local static ip. My router is pfsense running on a dedicated machine (not VM).

Calls between extensions are totally fine and the audio is create. The cell phone can here the user on the pbx end and vice versa.

Here’s also a screenshot showing SIPstation is running. I did just notice what appears to be an error with the ports.


#6

Sorry, I’m not a SIPstation user and don’t understand that error message. I assume that you have chan_sip binding to the default port of 5160.

I believe that I misunderstood your original post. On an outbound call, you don’t hear the ringback tone but once the call is answered there is audio both ways. Is that correct?

At the Asterisk command prompt, type
sip set debug on
and make a test call. The SIP trace will appear in the Asterisk log, along with the normal entries. Look to see that the outbound INVITE has the correct external address in the SDP, and that a 183 Progress is received when the called phone starts ringing. If that looks ok, capture traffic with tcpdump and check whether RTP is coming in during the ringing.

If you have trouble interpreting the SIP trace or log, paste the log at pastebin.freepbx.org and post the link here.


(Ryan) #7

Yes that is correct. The ringback tone cannot be heard.

Here is the last entry of the log. I’ve xxx’ed out a portion the public id address and phone numbers.

https://pastebin.freepbx.org/view/cb90f673

On thing I noticed that seems odd is this line:

[2020-02-07 23:40:12] VERBOSE[2337] chan_sip.c: Reliably Transmitting (NAT) to 192.159.66.3:5060:
OPTIONS sip:trunk1.freepbx.com SIP/2.0

That IP address scheme is not used on my local network. I have a 10.0.0.0 network.


#8

The SIP looks good. Confirm that your RTP forwarding is correct – option B in https://www.outsideopen.com/pfsense-asterisk/

If no luck, use tcpdump to see whether RTP is coming in during the ringing.


(Ryan) #9

Nice guide but I had everything set is correctly.

I wonder if the issue could be with the provider. My SIP number was just setup on 2-7-2020. I’ll contact them on the next business day and see if there’s something on their end or something they need me configure on mine.


(Ryan) #10

I did some more testing today by calling different numbers. It seems like some numbers I call, the system gives ringback tone while the call is connecting and some don’t. I called a few of my friends who have landlines into their residences and the ringback tone works. When I call cell phones, customer service centers, and other random numbers, I don’t get a ringback.

Anyone have any other thoughts on that? Thank you.


(Asteriskadmin) #11

are you using cisco phones? if so i would try with a SIP to a SIP phone not SCCP

[2020-02-07 23:39:23] VERBOSE[15944][C-00000009] app_dial.c: SIP/fpbx-1-FChexsS2jdnM-00000040 is making progress passing it to SCCP/2101-00000037

I would also switch from chan_sip to PJSIP

one more: not sure why you’re not getting these. maybe that’s a PJSIP thing?
VERBOSE[6849][C-00000040] app_dial.c: Local/xxxxxxxxxxx@from-internal-00000002;1 is ringing
or even
VERBOSE[6849][C-00000040] app_dial.c: PJSIP/XXXX-00000081 is ringing


#12

It should not be difficult to find out what is going wrong. IMO it’s very unlikely that the provider is at fault.

There are two ways that the carrier can indicate that the called party is being rung. One is to send a 180 Ringing status. With default settings, Asterisk sends the 180 on to the phone, which then plays a ringback tone to the caller from its own memory (there is no sound being sent by VoIP).

The other method is to send a 183 Session Progress status. After this is sent, the carrier sends audio with the ringback tone sound. If everything is working properly, Asterisk passes the audio to the called phone, which plays it.

I suspect that on some numbers the carrier is sending a 180 and the phone responds correctly. On others, including the failing call for which you posted a log, there is a 183 but the audio is not properly passed.

If you determine that this is the case, trace the audio from the carrier back to the phone. Running tcpdump on the PBX and analyzing with Wireshark, see whether good ringback tone is coming in from SIPstation and whether Asterisk is passing it to the correct IP address and port for the phone. If so, you then have to see whether the networking gear between the PBX and phone is doing the right thing.

I know nothing about SCCP and agree with @asteriskadmin that moving away from it, if feasible, may be the easiest solution. Otherwise, if there is an option for the phone to send audio during ‘early media’, try turning that on.

If you still have trouble, post details about the network path from PBX to phone.


(Ryan) #13

Yes I am using cisco phones. They work great internally. I can call other extensions, check email, pretty much everything I want to do. I’d rather not replace all of my cisco 7975 phones with brand new SIP phones due to cost.

I’m not sure how to use wireshark to look at the tcpdump data. I’ve downloaded the program and installed it but not sure what to do from there. Here’s what I got from the tcpdump:

22:22:54.902323 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21997264:21997456, ack 107361, win 3837, length 192
22:22:54.902352 IP 10.10.30.2.55097 > freepbx.sangoma.local.ssh: Flags [.], ack 21996960, win 8212, length 0
22:22:54.902437 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21997456:21997760, ack 107361, win 3837, length 304
22:22:54.902529 IP 10.10.30.2.55097 > freepbx.sangoma.local.ssh: Flags [P.], seq 107361:107521, ack 21997264, win 8211, length 160
22:22:54.902543 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21997760:21997952, ack 107361, win 3837, length 192
22:22:54.902615 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21997952:21998000, ack 107521, win 3837, length 48
22:22:54.902643 IP 10.10.30.2.55097 > freepbx.sangoma.local.ssh: Flags [.], ack 21997760, win 8209, length 0
22:22:54.902745 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21998000:21998560, ack 107521, win 3837, length 560
22:22:54.902841 IP 10.10.30.2.55097 > freepbx.sangoma.local.ssh: Flags [.], ack 21998000, win 8208, length 0
22:22:54.902867 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21998560:21998752, ack 107521, win 3837, length 192
22:22:54.902973 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21998752:21999056, ack 107521, win 3837, length 304
22:22:54.903077 IP 10.10.30.2.55097 > freepbx.sangoma.local.ssh: Flags [P.], seq 107521:107585, ack 21998560, win 8212, length 64
22:22:54.903103 IP freepbx.sangoma.local.ssh > 10.10.30.2.55097: Flags [P.], seq 21999056:21999248, ack 107585, win 3837, length 192


(Ryan) #14

On another note. I am also trying to get a POTS line to work with the pbx as well. I am using a Obi110 and I used this guide to get it connect. https://wiki.freepbx.org/pages/viewpage.action?pageId=4161594

I followed the guide exactly and I am getting similar issues like I am having with the SIP service. When I call into my pbx from the outside, it rings my extension 4 times and then drops the call. If I answer the incoming call, I can here audio coming into the extension but I am unable to get any audio outbound from the extension.

Also when making outbound calls, no audio can be heard on the receiving end.

Hopefully this makes sense. I think this also confirms that the issue is on the pbx side and not the service provider.


(Ryan) #15

I was able to fix the issue I was having with my OBi110. I had the OBi110 on a different subnet and I did not add the correct network under the general sip settings. When making outbound calls using the OBi110, I can hear a ringback tone and everything works as normal.


(Asteriskadmin) #16

i would capture what the phone receives with wireshark. that way you can see if it’s 180 or 183 and if the RTP stream is getting to it or not. you can also double check if 180 works and 183 doesnt, etc

i would suggest using a SIP phone instead of SCCP just for testing purposes, you don’t have to change out everything in your org for that

wireshark has a telephony tab -> VOIP calls as well as RTP -> all or RTP streams. they move these around for different versions and use different names. There’s also SIP flows in newer versions.
play around with the app it’s quite capable and mostly intuitive.


(Ryan) #17

I was able to look at the tcp dump with wireshark.

I am seeing a lot of “401 Unauthorized”


#18

Those are not errors, if the request is repeated with an Authorization header and the second request is accepted.


(Ryan) #19

Ok. Here’s a couple screen shots of what I am seeing. I’m not really sure what I should be looking for. :frowning:


#20

Most of the 401s are responses to INVITEs from IPs in Germany, most likely hack attempts (unless you have a trunk with them that’s not set up correctly). See http://whois.domaintools.com/77.247.108.89 .

However, the call initiated in packet 50 was sent to Bandwidth.com, who sent a 183 with associated audio. However, (assuming that the capture was not filtered), Asterisk did not send the audio onward to the extension, so you need to find out why.

I know nothing about SCCP so if you need help with that, I hope someone else will chime in.