No matching endpoint found


(Ian Arman) #1

Hello,

I’m receiving the following error when receiving a call on freepbx:

NO MATCHING ENDPOINT FOUND.

I’m following the following doc.

I’m able to make outbound calls properly - however receiving seems to be an issue


#2

Make sure that the Match (Permit) field for your trunk(s) allow all relevant Twilio signaling addresses.
https://www.twilio.com/docs/sip-trunking/ip-addresses

The second log entry was an attempted attack from China, unrelated to your present problem. After you get calling working properly, set up FreePBX firewall and/or your hardware firewall to allow only authorized address to connect.

If you still have trouble (or post again for another issue), don’t post text as an image. If less than 20 lines, just paste it into your message. Larger, paste it at pastebin.freepbx.org and post the link. If you need to post an image, just drag it to the compose window.


(Ian Arman) #3

Hello,

I added the following ip ranges to the firewall as local trusted networks.image

However, I’m still receiving the same error message:

This time it’s from the correct IP address which I allowed:

[2020-12-28 19:27:09] NOTICE[4344]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request 'INVITE' from '<sip:Anonymous@ottawakaraoke-001.pstn.twilio.com>' failed for '54.244.51.2:5060' (callid: 535c5fc9393796b312449666c9d87eb3@0.0.0.0) - No matching endpoint found
```````````````````````````````

#4

This is not a firewall issue. If pjsip displays an error, the request got to pjsip, i.e. it passed through the firewall successfully.

In the pjsip settings for your trunk, Advanced tab, Match (Permit) field, fill in the addresses from which Twilio may send calls:
54.172.60.0/30
for Virginia
and
54.244.51.0/30
for Oregon.


(Ian Arman) #5

i’m wondering where would be the correct settings.

or should i add this into the fields below

image


(Ian Arman) #6

hey,

I found the correct settings.

I had to create a new trunk
image

Then add the Ip addresses in the ‘match’ field like you said.

I guess this trunk is used for ‘incoming’ - and my other trunk is used for outgoing.

Both call flows are working.

Interestingly enough:

1/ I’m using VirtualBox 1 GB Memory
36 GB Virtual Space.

and I’ve got perfect call quality.