FreePBX | Register | Issues | Wiki | Portal | Support

No Incoming calls


(Peter Tasker) #1

Hi Guys,

I would really appreciate some help.

I have FreePBX running on a Raspberry Pi 3 with counterpath Xlite softphones on all PC’s/Macs (4 in total) Zoiper softphones running on a Iphone and an Android phone all setup as extensions on FreePBX. In addition I have a Yealink cordless phone setup as an extension. Also I have an analogue phone setup as an extension using a Linksys SPA3102. The SPA3102 also provides the interface to my PSTN (copper wire) connection.

The FreePBX trunk is set up as a PJSIP trunk and the SPA3102 Line & PSTN are all showing as “Registered” and the SPA3102 has been setup using the various guides found via Google.

All extensions can call one another, all extension can call out to the PSTN.

My issue is with incoming calls, any incoming caller recieves ringing tone ok, but the ringgroup I have set up on the FreePBX never rings (I have tried setting the destination on the “inbound route” as an extension, but this still does not work.

So I have exhausted all my limited knowledge and would really appreciate some guidance, so any suggestions, hints, tips etc. would be gratefully accepted.

Peter


(Peter Tasker) #2

My FreePBX version is;

Current Asterisk Version: 13.17.1

My SPA3102 FW is 3.3.6(GW)

Peter


(Itzik) #3

Do you see the calls in CDR? Can you provide some logs? Ty


(Peter Tasker) #4

Hi, No there are no I/C calls in the CDR. Very happy to provide logs. which logs would be good?

Thanks

Peter


(Itzik) #5

You probably don’t have your inbound settings on your trunk or inbound route correct.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug

(in short, make a incoming call and post the logs you see in /var/log/asterisk/full you can also monitor the logs live, from cli asterisk -rvvv)


(Peter Tasker) #6

Sorry, I have tried open the logs, cli (-rvvv) from asterisk does not work and addition I cannot get logs to run via SSH. I am running FreePbx on a raspberry Pi3 - not sure if this is a problem re logs.

Peter


(Peter Tasker) #7

Ok so I have figured out how to use the log system. When I make an incoming call there is NO log activity.

I can see the logging is working Ok as I can see a good output when making O/G calls.

So now I am really stumped.

Peter


(Itzik) #8

Either is your Trunk not configured correctly, or your firewall-network isn’t allowing any traffic to the PBX.

Another note, if the above is actually setup right, then try to setup a chansip Trunk for testing…


(Peter Tasker) #9

Here is the SPA3102 PSTN Line config.




I have erased the main part of the PSTN number in these files for security purposes :rofl:


(Dave Burgess) #10

I’ve never used one of these, but the PSTN-To-VOIP Gateway settings don’t look right.

In a general sense, inbound and outbound calling are actually different processes, so getting outgoing calls to work is largely unrelated to inbound calling working. If you are not getting notified of an inbound call, it’s either because the SPA3102 isn’t set up to connect to your PBX, or your PBX is not set up to answer the incoming SIP connection from the SPA3102. With your setup (as documented), I’m pretty sure you have your SIP information set incorrectly on the SPA, and I’m not confident your trunk for the inbound calls is set up correctly as well.


(Peter Tasker) #11

Thanks Dave, I appreciate your reply.

The SIP is setup on Port 5061 (the line is on 5060) and both the line & PSTN are showing as “Registered”. If I change the SIP port then the registration fails. So my conclusion is the the PSTN SIP is talking to the PBX ok.

Any suggestions re the SIP settings would be gratefully received,

Petert


(Dave Burgess) #12

I have no idea what you mean.

Which SIP where and what?

What line is on 5060?
PSTN SIP isn’t a thing. PSTN is an analog channel that comes into your device on a two-wire cord - SIP is an Internet Protocol that runs on Ethernet.

Where are the lines showing “Registered”?

I’m so confused right now that I can’t figure out what you are trying to do anymore.

Can we simplify this for a minute? Your SPA is connected to an analog phone line. It has at least one Ethernet connection to your FreePBX server. This connection should be available full time.

On the SPA, you connect to the SIP port on the FreePBX Server. Note that both devices have a listening port number and both are likely to be 5060 (since that’s the well-known port address for SIP).

The log files (/var/log/asterisk/full) will tell you what is and isn’t working. I have yet to see those logs, so I’m still not convinced that what you think is happening is what is actually happening. I think your next troubleshooting step will need to be reviewing those logs and trying to figure out what is not working. I’ve already said that your SPA configuration looks wrong, but without knowing what the failures are on the PBX there’s no way of knowing.


#13

By default the SPA’s will use udp port 5060 signalling for the FXS connection and port 5061 for the FXO connection, FreePBX should register the FXS as an extension (udp port 5060) the OP’s SIP, and the FXO as a trunk (using host=ipaddress and port=5061) the OP’s ‘line’


(Peter Tasker) #14

Well I am hitting my head up against a brick wall (and it is starting to hurt ). I still cannot get incoming calls to work. Having turned on the logging on the SPA3102 and initiating and I/C call I find the following;

DLG Terminated 2e1c30
Sess Terminated
POL REV -51 51
FXO:OnHook PolRev
FXO:Start CNDD
CC:Clean Up
— OBJ POOL STAT —
OP:RTPRXB = 96 ( 96 192) OP:RTPREB = 40 ( 40 48)
OP:RTPTXB = 64 ( 64 108) OP:TIMEOU = 110 (120 52)
OP:SIPCOR = 0 ( 1 28) OP:SIPCTS = 32 ( 32 580)
OP:SIPSTS = 32 ( 32 6064) OP:SIPAUS = 6 ( 8 588)
OP:SIPDLG = 10 ( 10 148) OP:SIPSES = 12 ( 12 8192)
OP:SIPREG = 2 ( 4 468) OP:SIPLIN = 0 ( 2 140)
OP:SUBDLG = 2 ( 2 6444) OP:STUNTS = 16 ( 16 68)

caller id parse number=07860xxxxxx
fxo cnddwrap_feed parse ok 07860xxxxxx status=2
– Caller ID:
– Name = (null)
– Remote Number = 07860xxxxxx
– Dialable Number = (null)
– No Number Reason = (null)
– No Name Reason = (null)
– Message Waiting = (null)
– Date and Time = 02/02 09:06
FXO:CNDD name=, number=07860xxxxxx
FXO:Stop CNDD

FXO:Start CNDD
[1]<<192.168.1.80:5060(426)
[1]<<192.168.1.80:5060(426)
OPTIONS sip:PSTN@192.168.1.151:5061 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.80:5060;rport;branch=z9hG4bKPjfe2ef7f3-7f34-4b74-b314-9f33b4bf646d
From: sip:PSTN@192.168.1.80;tag=12ade42c-d47c-47fc-8829-a33110c1b014
To: sip:PSTN@192.168.1.151
Contact: sip:PSTN@192.168.1.80:5060
Call-ID: 88bc1f61-da16-4bf8-a621-208283b15d13
CSeq: 40268 OPTIONS
Max-Forwards: 70
User-Agent: FPBX-14.0.1.20(13.18.3)
Content-Length: 0

Can anyone decipher the above? FreePBX also has logging switched on and shows NO activity.

All O/G call as OK.

The SPA3102 has an IP address of 192.168.1.151, the FreePBX has an IP address of 192.168.1.80 (both are static)

Thanks in advance

Peter