"No Conference Room App" on the panel despite having confbridge installed

Hi all.

I’m looking this message on the FreePBX panel:

“No Conference Room App”: Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly.

The confbridge module is installed:

[email protected]:/usr/lib/asterisk/modules# ll | grep confbridge
-rwxr-xr-x 1 asterisk asterisk  914512 jul 24 21:20 app_confbridge.so

Meetme is not installed (I’m not using DAHDI with this installation). On Settings -> Advanced Settings -> Conference Room App, I’ve configured app_confbridge.

What could be the problem?

Thanks in advance.

Kind regards,
Daniel

Is confbridge loaded, check from the Asterisk CLI:

CLI> module show like app_confbridge.so
Module                         Description                              Use Count  Status      Support Level
app_confbridge.so              Conference Bridge Application            0          Running              core
1 modules loaded

Hi, Lorne.

Thanks for your reply.

It seems to be loaded:

pbxtest*CLI> module show like app_confbridge.so
Module                         Description                              Use Count  Status      Support Level
app_confbridge.so              Conference Bridge Application            0          Not Running          core
1 modules loaded
pbxtest*CLI>

Kind regards,
Daniel

Check again:

Status      
Not Running

Hi, Lorne.

I have noticed it. But “Not running” means that it is not loaded or it is loaded and it was not being used at that time (because there was not an ongoing conference)?

Kind regards,
Daniel

Hi again.

Well, it seems that is not the second case because I did a similar test with chan_pjsip and despite not having ongoing calls the status was “Running”. So should I activate confbridge using some option of FreePBX?

Kind regards,
Daniel

I have the very same issue. Fresh install of 13/13. Did all the updates and everything. Interesting issue.

Module Description Use Count Status Support Level
app_confbridge.so Conference Bridge Application 0 Not Running core
1 modules loaded

Hi, bigunk.

Have you been able to solve it?

I tried adding this module on Admin->Asterisk Modules->Preloaded Modules, but this made no difference.

Any help/hint will be appreciated.

Thanks in advance.

Kind regards,
Daniel

Hey guys, I came with same issue.
After I looked the error on Dashboard “Neither app_meetme nor app_confbridge is configured in Asterisk”, I was checking app_confbridge.so module was on asterisk.
It was on modules dir, but not loaded. After trying to load, I get notice that no /etc/confbridge.conf can be loaded, there wasn’t the file.

If I create an empty confbridge.conf file it loads, but I think is not working of course and error on FreePBX Dashboard persist.

I installed freePBX 13, AST 13 on Centos 6.8 from scratch on a OpenVZ on Proxmox VE, following this tutorial (DAHDI and Google voice not installed):
http://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+6

Could this be a bug?
There are many things commented about, but I really don’t understand it:
http://issues.freepbx.org/browse/FREEPBX-5174?jql=text%20~%20"confbridge"

I hope we can find the solution.
Thanks!

Hi, elkato.

Thanks for sharing this information. It is interesting what you mention.

Looking at my installation, the only file that I found was a empty file in the directory with the sources of Asterisk.

[email protected]:/etc/asterisk# find / -name confbridge.conf
/usr/src/asterisk/configs/basic-pbx/confbridge.conf

Then I copied it to /etc/asterisk, adapting the permissions:

[email protected]:/etc/asterisk# cp -a /usr/src/asterisk/configs/basic-pbx/confbridge.conf .
[email protected]:/etc/asterisk# chown asterisk.asterisk confbridge.conf
[email protected]:/etc/asterisk# chmod 664 confbridge.conf

Then run a core reload, but without changes:

pbxtest*CLI> module show like app_confbridge.so
Module                         Description                              Use Count  Status      Support Level
app_confbridge.so              Conference Bridge Application            0          Not Running          core
1 modules loaded

Kind regards,
Daniel

Hi again.

I tried to manually load the module and it seems to work:

pbxtest*CLI> logger set level VERBOSE on 
Logger status for 'VERBOSE' has been set to 'on'.

pbxtest*CLI> module load app_confbridge.so
Loaded app_confbridge.so
  == Parsing '/etc/asterisk/confbridge.conf': Found
[2016-10-24 12:47:41] NOTICE[18708]: confbridge/conf_config_parser.c:2072 verify_default_profiles: Adding default_bridge profile to app_confbridge
[2016-10-24 12:47:41] NOTICE[18708]: confbridge/conf_config_parser.c:2083 verify_default_profiles: Adding default_user profile to app_confbridge
[2016-10-24 12:47:41] NOTICE[18708]: confbridge/conf_config_parser.c:2094 verify_default_profiles: Adding default_menu menu to app_confbridge
  == Registered channel type 'CBRec' (Conference Bridge Recording Channel)
  == Registered channel type 'CBAnn' (Conference Bridge Announcing Channel)
  == Registered application 'ConfBridge'
  == Registered custom function 'CONFBRIDGE'
  == Registered custom function 'CONFBRIDGE_INFO'
  == Manager registered action ConfbridgeList
  == Manager registered action ConfbridgeListRooms
  == Manager registered action ConfbridgeMute
  == Manager registered action ConfbridgeUnmute
  == Manager registered action ConfbridgeKick
  == Manager registered action ConfbridgeUnlock
  == Manager registered action ConfbridgeLock
  == Manager registered action ConfbridgeStartRecord
  == Manager registered action ConfbridgeStopRecord
  == Manager registered action ConfbridgeSetSingleVideoSrc
 Loaded app_confbridge.so => (Conference Bridge Application)

pbxtest*CLI> module show like app_confbridge.so
Module                         Description                              Use Count  Status      Support Level
app_confbridge.so              Conference Bridge Application            0          Running              core
1 modules loaded

Is there a way to automate the loading of the module with FreePBX?

Moreover, even with the running module, the error in FreePBX persists. Any idea why this happens?

Thanks in advance.

Kind regards,
Daniel

Hi again!

I’ve restarted the LXC container and now the module was automatically started. After some time, I see that the error has disappeared from FreePBX saying now: “System Alerts: No critical issues found”. But I’m not sure if the module was automatically started because I added it manually on Admin->Asterisk Modules->Preloaded Modules.

Kind regards,
Daniel

Daniel, after I wrote I’ve solved the alarm showed at Dashboard.

I’ve looked in Inet for the original config file confbridge.conf and filled in file (For Asterisk 13 https://github.com/asterisk/asterisk/blob/master/configs/samples/confbridge.conf.sample)

After it, on Freepbx, Admin, Asterisk modules, you can add there (app_confbridge.so).
I don’t remember now what more I did (I think nothing else) and after that the error on Dashboard went away.

I hope that help.

BTW, are you from LATAM? speak spanish or portugues? let me know by prirv. thanks

This file should be getting added from the conferences module. If you look in /var/www/html/admin/modules/conferences/etc you will see it in there. This file should be getting symlinked.

I’ve restarted the LXC container

This was probably a permissions issue.

Hi, Andrew.

Thanks for your reply.

I’m not finding the path /var/www/html/admin/modules/conferences/etc:

[email protected]:/var/www/html/admin/modules# ll
total 68
drwxrwxr-x  2 asterisk asterisk 4096 nov  3 08:24 _cache
drwxrwxr-x  6 asterisk asterisk 4096 jul 24 22:49 callrecording
drwxr-xr-x  7 asterisk asterisk 4096 sep 12 15:45 cdr
drwxr-xr-x  7 asterisk asterisk 4096 sep 16 20:41 cel
drwxr-xr-x 10 asterisk asterisk 4096 oct 25 13:38 core
drwxrwxr-x  5 asterisk asterisk 4096 jul 24 22:49 customappsreg
drwxrwxr-x  8 asterisk asterisk 4096 jul 24 22:49 dashboard
drwxrwxr-x  5 asterisk asterisk 4096 jul 24 22:49 featurecodeadmin
drwxr-xr-x  3 asterisk asterisk 4096 nov  3 08:16 framework
drwxrwxr-x  3 asterisk asterisk 4096 jul 24 22:49 infoservices
drwxrwxr-x  6 asterisk asterisk 4096 oct 18 19:54 logfiles
drwxrwxr-x  5 asterisk asterisk 4096 ago  1 13:49 miscdests
drwxrwxr-x  5 asterisk asterisk 4096 sep  6 14:29 music
drwxrwxr-x  5 asterisk asterisk 4096 oct  7 18:52 sipsettings
drwxr-xr-x  7 asterisk asterisk 4096 oct 25 20:52 ucp
drwxrwxr-x  8 asterisk asterisk 4096 oct 18 16:26 userman
drwxr-xr-x  6 asterisk asterisk 4096 oct 31 20:23 voicemail

On the other hand, these was the steps I took to install Asterisk:

[email protected]:/usr/src/asterisk# makemenuselect
[email protected]:/usr/src/asterisk# make
[email protected]:/usr/src/asterisk# make install
[email protected]:/usr/src/asterisk# make config (init script)
[email protected]:/usr/src/asterisk# make install-logrotate
[email protected]:/usr/src/asterisk# ldconfig
[email protected]:/usr/src/asterisk# update-rc.d -f asterisk remove

I think there is an option of make, make samples, but I thought it was not recommended for use with FreePBX. Maybe that make samples copies to /etc/asterisk the configuration file for Confbridge.

Kind regards,
Daniel

Make samples will completely mess up freepbx. That should have never been run

You don’t have the conferences module. Go to module admin and install it.

Hi, Andrew.

Thanks for your reply.

I never ran make samples in the installation of Asterisk because I remembered reading that it was not advisable with FreePBX.

Thanks for the suggestion. I installed the “Conferences” module with its dependencies (“Recordings”, which in turn depends on “Soundlang”) and now I see the mentioned files:

[email protected]:~# ll /etc/asterisk/confbridge.conf
lrwxrwxrwx 1 asterisk asterisk 59 nov  3 18:38 /etc/asterisk/confbridge.conf -> /var/www/html/admin/modules/conferences/etc/confbridge.conf

But what’s not clear for my is why FreePBX gave the ConfBridge error if the FreePBX module was not installed.

Kind regards,
Daniel

Same problem here on two installs.

It seems that the install on Centos 7 works fine but on Centos 6.8 it fails.

This should no longer be an issue on hand installs moving forward. We simply added the conferences module to the tarball.