No auth objects matching realm(s) '' from challenge found

Hi!

I have FreePBX running on VM on my home server. It’s been working for years now and I’ve been very happy with it. However- I’ve been trying to use my PBX and VoIP telephones with SIP number provided by orange with my internet. When I finalny got SIP Trunk to register it’s giving me the same warning over and over:

WARNING[23655] res_pjsip_outbound_authenticator_digest.c: Host: ‘83.0.8.193:5060’: No auth objects matching realm(s) ‘’ from challenge found.

Inbound nor outbound calls seem to work. When I’m trying to call my mobile phone from my Fanvil it’s giving me this:

14158 [2024-05-19 01:06:10] VERBOSE[23655] netsock2.c: Using SIP RTP Audio TOS bits 184
14159 [2024-05-19 01:06:10] VERBOSE[23655] netsock2.c: Using SIP RTP Audio TOS bits 184 in TCLASS field.
14160 [2024-05-19 01:06:10] VERBOSE[23655] netsock2.c: Using SIP RTP Audio CoS mark 5
14161 [2024-05-19 01:06:10] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:1] ResetCDR(“PJSIP/200-00000003”, “”) in new stack
14162 [2024-05-19 01:06:10] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:2] NoCDR(“PJSIP/200-00000003”, “”) in new stack
14163 [2024-05-19 01:06:10] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:3] Progress(“PJSIP/200-00000003”, “”) in new stack
14164 [2024-05-19 01:06:10] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:4] Wait(“PJSIP/200-00000003”, “1”) in new stack
14165 [2024-05-19 01:06:11] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:5] Playback(“PJSIP/200-00000003”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
14166 [2024-05-19 01:06:11] VERBOSE[28821][C-00000004] file.c: <PJSIP/200-00000003> Playing ‘silence/1.g722’ (language ‘pl’)
14167 [2024-05-19 01:06:12] VERBOSE[28821][C-00000004] file.c: <PJSIP/200-00000003> Playing ‘cannot-complete-as-dialed.g722’ (language ‘pl’)
14168 [2024-05-19 01:06:14] VERBOSE[28821][C-00000004] file.c: <PJSIP/200-00000003> Playing ‘check-number-dial-again.g722’ (language ‘pl’)
14169 [2024-05-19 01:06:17] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:6] Wait(“PJSIP/200-00000003”, “1”) in new stack
14170 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Executing [MYNUMBER@from-internal:7] Congestion(“PJSIP/200-00000003”, “20”) in new stack
14171 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Spawn extension (from-internal, MYNUMBER, 7) exited non-zero on ‘PJSIP/200-00000003’
14172 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Executing [h@from-internal:1] Macro(“PJSIP/200-00000003”, “hangupcall”) in new stack
14173 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Executing [s@macro-hangupcall:1] GotoIf(“PJSIP/200-00000003”, “1?theend”) in new stack
14174 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx_builtins.c: Goto (macro-hangupcall,s,3)
14175 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Executing [s@macro-hangupcall:3] ExecIf(“PJSIP/200-00000003”, “0?Set(CDR(recordingfile)=)”) in new stack
14176 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Executing [s@macro-hangupcall:4] Hangup(“PJSIP/200-00000003”, “”) in new stack
14177 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] app_macro.c: Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘PJSIP/200-00000003’ in macro ‘hangupcall’
14178 [2024-05-19 01:06:18] VERBOSE[28821][C-00000004] pbx.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘PJSIP/200-00000003’

I’ve checked every webside covering this topic and haven’t found a solution that would work for me.
It’s working just fine with my Cisco Internet Phone Adapter (VoIP to analog phone gateway) with no configuration whatsoever (other than SIP Server adress and credentials like username, auth username and password).

I’ll gave more information if needed.

Best regards,
Kacper

Does your carrier accept g722 ?
Is “MYNUMBER” acceptable by your carrier?

  1. Yes
  2. It’s my way of censoring my phone numer. In reality when there’s “mynumber” there is e.g. “817392612”.

Then in what country are you?
is ‘817392612’ a format the carrier will accept?

Where is this system? Your language is set to Polish, Kacper is a Polish name and 817392612 is correct formatting for a number in Poland. However, 83.0.8.193 is an address in UK, your last post was at 2:45 AM CEST, and 817392612 would be a landline number in Lublin, not a mobile, so some things look strange. (Orange operates in both Poland and UK.)

In any case, “your call cannot be completed as dialed” is played when the number received from the extension does not match any Outbound Route. If there was a problem past that (trunk not registered or not online, provider rejected call, etc.) you would instead hear “all circuits are busy now”.

Confirm that MYNUMBER (what the Fanvil is sending) is what you dialed. If not, adjust its settings so it doesn’t rewrite the number. Next, check that your Outbound Route matches that. If not, adjust the patterns to match all the number formats you will be using.

Once you get past those, if you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing test call, paste the Asterisk log for the call at pastebin.com and post the link here.
Call a number that you don’t have to redact (for example, a local McDonald’s). If you redact other information (your number, username, public IP, etc.), make it clear what each changed value represents.

Poland and yes, we have 9 digits in our phone numbers [and a country number, like +48 for Poland, but it’s only necessary for cross-country dialing].

I would prepend +48 anyway, few providers limit their operations to one country and e164 dialing is uniquely resolvable and most voip providers accept it.

This sounds like a low level authentication problem, possibly the result of incorrect proxy routing, rather than related to telephony level issues. I’d want to see the pjsip set logger on output, from the full log, for the failed INVITE transaction.

I haven’t found any obvious issues with the inbound or outbound settings (though I’m not sure, I’m just doing this for fun and I’m not confident about the configurations). After calling the McDonald’s number, the Asterisk Log Files show this:

(I haven’t censored any information; I copied exactly what was displayed.)

Does anything in this point to a specific problem?

If I understood your request correctly, the link is in the response above.

This is what is causing the error in the subject.

|140282|SIP/2.0 407 Proxy Authentication Required||
|---|---|---|
|140283|Call-ID: d4575621-3725-4964-a4f9-e34804708ca1||
|140284|Via: SIP/2.0/UDP 83.27.125.87:5060;received=83.10.224.65;branch=z9hG4bKPj169ca091-f84f-4d43-9f40-887d734320b1;rport=3896||
|140285|To: <sip:[email protected]>;tag=65aeda06-664a60fcfe3d367||
|140286|From: <sip:[email protected]>;tag=5a3d8b52-966b-4a9e-ae25-b162fb97b0c8||
|140287|CSeq: 26835 OPTIONS||
|140288|Date: Sun, 19 May 2024 20:28:44 GMT||
|140289|Content-Length: 0||

However this is for OPTIONS, and it is potentially acceptable, unless it causes the provider to black list you. Assuming you aren’t being blacklisted for repeated failures to authenticate, the subject reason is not relevant.

The actual failure on the call is:

|140297|SIP/2.0 503 Service Unavailable||
|---|---|---|
|140298|Via: SIP/2.0/UDP 192.168.1.107:5060;rport=5060;received=192.168.1.107;branch=z9hG4bK30090157362641214407||
|140299|Call-ID: [email protected]||
|140300|From: Kacper <sip:[email protected]>;tag=1419919835||
|140301|To: 48222115800 <sip:[email protected];user=phone>;tag=de347c40-526d-4dc6-ba99-4d10bf90c243||
|140302|CSeq: 2 INVITE||
|140303|Server: FPBX-16.0.40.4(18.13.0)||
|140304|Allow: OPTIONS, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, MESSAGE, REFER||
|140305|Reason: Q.850;cause=34||
|140306|Content-Length: 0||

Cause 34 is:

Cause No. 34 - no circuit/channel available [Q.850]
This cause indicates that there is no appropriate circuit/channel presently available to handle the call.

I think 34 is sometimes used when the dialled number is not in an acceptable format, but different providers interpret codes differently, and it is best to ask the specific provider.

OOPS. Asterisk is sending the 34, not receiving it. As others have pointed out, it is because you don’t have an outbound route, and your headline issue is definitely irrelevant.

You still have a problem with your Outbound Route – there was no match for 48222115800.
For testing, try setting an Outbound Route with

prepend: (leave blank)
prefix: (leave blank)
match pattern: X.
CallerID: (leave blank)

This will match any number you dial and send it unchanged.
Then, try dialing 222115800 as well as 48222115800

There also seem to be problems with your trunk settings. Assuming that the instructions from neofon in this thread are still accurate:

Try using these settings for your trunk (my reply in that thread is obsolete, because an Auth username setting has been added to FreePBX):

Username: 48757462894
Auth username: [email protected]
Secret: (password supplied by Neofon)
SIP Server: neofon.tp.pl
SIP Server Port: 5060
Contact User: 48757462894
From Domain: neofon.tp.pl
From User: 48757462894
Client URI: (leave blank)
Server URI: (leave blank)

If the Neofon instructions have changed, or if you have it working with a softphone or a different PBX, please explain.

If the trunk does not register with above settings, paste a log of a registration attempt and associated replies.

Also, there seems to be a discrepancy between the public IP address configured in Asterisk and the one seen by Neofon:
See line 200 of the log, which shows:
140284 Via: SIP/2.0/UDP 83.27.125.87:5060;received=83.10.224.65;branch=z9hG4bKPj169ca091-f84f-4d43-9f40-887d734320b1;rport=3896
Confirm that External Address in Asterisk SIP Settings matches the WAN IP address of your router, and what you see when visiting whatismyip.com . If the latter two are different, please explain.

If the trunk is registered ok but still can’t make calls, paste a new log.

If inbound is still failing: What, if anything, appears in the Asterisk log on an attempted call? If nothing, what, if anything, appears in sngrep? If also nothing, post details of router/firewall. If it doesn’t have a public IPv4 address on its WAN interface, please explain.

I didn’t check the direction of the 503. Asterisk never sent an INVITE, and, as others have pointed out, that means an outbound route problem. There may be a proxy authentication issue, but you aren’t getting that far.

if you don’t prepend +48 you probably need to prepend 0048

‘+’ is a metacharacter (long press 0 on a cell/mobile phpne) GSMA invented for a locale’s international exit code, 00 for most places, 011 for NANPland

I think the + format was recommended, for printed documents, before digital mobile phones existed. As far as I know, GSM phone actually send type of number = international and don’t send the outbound prefix, when you use +.

Hi! Sorry for the late reply. I wasn’t able to get to this earlier. After changing the Outbound Route according to your recommendations and adjusting my trunk settings, I managed to make an outbound call. Here are the logs from that call:

Unfortunately, the incoming call still didn’t work. I didn’t even notice any information in the logs.

After about 10 minutes, the call stopped working, and the phone responded that all internal numbers were busy. Here are the logs:

My external IPv4 address is dynamic, so I don’t have the option to set it correctly. For now, I’ve left this field blank.