No audio with certain caller IDs


(Italy) #1

Im experiencing some problems with inbound and possibily outbound calls,
I have a SIP number linked with a misc destination which dials an outbound number with a caller ID.

The problem is, with most caller ids there is no audio, either incoming or outgoing. There is audio only with caller IDs like +391111111111 or +392222222222. I have tried calling the destination without passing from the sip number and everything works fine with caller ids different from the ones i just mentioned, i’ve already checked with the trunk provider and everything is fine on my account and on their end.

Can someone help me?


#2

AFAIK, landline numbers in Italy have a 0 after the +39 and mobiles have a 3. Please explain what you are indicating by starting with 1 or 2.

Also, let us know the format of numbers that don’t have audio.

If this is an on-site PBX behind a NAT, confirm that your router/firewall is forwarding the RTP port range (default is UDP 10000-20000) to the PBX.


(Italy) #3

You are correct with the distinction between landline and mobile numbers, i started with a 2 and a 1 because i found that “+392222222222” and “+391111111111” (literally) are the only outgoing caller IDs that i can set in the system that don’t cause the audio problem.

The format of the numbers that don’t have audio its compliant to E.164

The RTP port range is forwarded correctly


#4

As a test, route the incoming call to a brief Announcement and then to the misc destination. Report whether the caller hears the announcement and what (if anything) he hears after that. If still no audio from the outbound leg, please paste the Asterisk log of a failed call, including a SIP trace at pastebin.freepbx.org and post the link here.

If you are too new to post links, just post the last 8 hex characters.

For the SIP trace, before making the test call, at the Asterisk command prompt type
pjsip set logger on
and/or
sip set debug on
according to your trunk type(s).


(Italy) #5

I already made this test before making this post, with playback playing after callee answers the call (this time with a different caller id from the ones mentioned before) using the A(x) argument from the Dial application and it worked flawlessly, but after that, no audio.

I tested the inbound route too, and i hear the audio playing from the inbound call by changing the destination of the route


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.