No audio on internal calls

I have recently installed FreePBX (Asterisk 16.6.2) to see if it is suitable to replace our ten-year old VoIP system. I have set up two extensions and got two phones (both Grandstream, one GXP2110 and one GXP2020) to register. The phones can call each other, but there is no audio on the calls at all. I do get audio from the system, e.g. voicemail prompts and errors when I call non-existent extensions. I’m entirely stumped, does anyone have any suggestions for what I might be doing wrong?

sample call pastebin:

This thread seems to be describing the same issue, the workaround there was to install FreePBX 14:

Hi, the issue got solved by configuring the local settings at the asterisk sipsettings. You can try that and then test again.

The local network settings? I have my subnets added there and the issue is still persists.

I don’t recommend Asterisk 15 for a new system, as it is already EOL. See

At the Asterisk command prompt, type
pjsip set logger on
or, if you are using legacy chan_sip extensions, type
sip set debug on
make a (failing) test call, paste the complete Asterisk log for the call at and post the link here.

Okay. I made a mistake there and got the version for the wrong thing. I double checked and we’re using 16.6.2; I will edit my OP.

The system or the phones, I’m not sure which, disconnects the call after about 30 seconds of no audio.

In Asterisk SIP Settings, set Local Networks to / 16 / 12
and set External Address to your public IPV4 address.

Submit, then restart (not just reload) Asterisk.

Retest, if you still have trouble, post a new log.

1 Like

That fixed it.

It’s rather bizarre that internal calls need the external IP address to be set correctly on a server without any trunks set up yet. I never would have found that on my own. Thank you for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.