I am needing help. I have been using 3cx and want to change to FreePBX. I have the trunk registered, but I can not get any of the extensions to register. I have checked and recheck and everything looks fine to me. I am sure it is just something little that I am missing. I wish someone could help me get them to work and I think I can take it from there. I am so excited about using the program. Thank you in advance for any help or suggestions. I show I have one trunk running, but right now I have 5 extensions hooked up and none of them are showing, they are grandstream phones. PLEASE HELP ME, I have been two weeks on this, at one time I got one to show, but nothing now. I compared everything and all seemed to be the same. Thanks again and hope someone will assist me with this.

I am trying to set up FreePBX Distro. I have followed all the instructions step by step. I am using Vonage as my SIP and I am showing it is active.
PBX Firmware: 1.1009.210.62-1
PBX Service Pack:
I am using Grandstream phones, which are still set up the same as they was with 3CX. I am unsure of what you are really needing, as I mentioned, I am really unsure on what I am doing with this program. I did find some information on using Vonage on from a link I got. It seemed as if I was to put this into the programming. This is something I do not know how to do. I did make corrections that I found from this information where I could in distro. This is the link that I got I hope you can be a little patient with me, as I believe I have filled out all the places I knew the answers in Distro from the information I got from the link. But as I said, it looked as if I was to put this into the program itself, and the only think I know how to do right now is to insert information in the program itself. I do hope I am making some sense. I have had 3cx working for many years. So this is all new to me, and would like to learn more. I have read what I can. So as a beginner, I can answer what question I can find for you. I am grateful that you have been willing to help and hope that you will continue. I did graduate from collage with a computer science degree. But back then, we didnt study this kind of stuff considering I am 55 years old. Again, Thank you for getting back with me, but please understand I have just started to learn about this. All of it is new, but I am trying real hard to understand.
It all seems great so far, other then my extensions are not connecting to distro. They are connecting to my server, because I can access them by interring their ip addresses. They just are not showing up in distro.
I am sure I have not answered all, if you let me know more details, I will see what I can do. Thank you for you concern.

Daniel I responded to you last week when you posted the same plea. All the begging in the world is not going to get you any help unless you help yourself and explain exactly what you have done.

Your last post you did not have the basic concept of provisioning phones.

Have you read a few getting started guides?

You need to post exactly what software you have, so many different versions of FreePBX

You need to tell us exactly what you have done, how your network is setup. How the phones are configured etc.

Take a deep breath, don’t expect anyone to read your run-on sentences, there is both an enter key to separate your points. There are many ways to get help. Nobody needs anything from you, you need everything from them, even if you are 55 that is no excuse, I am older, but if you can’t isolate your points, one by one there is little chance that anyone will do that for you. Do you not agree that if you look at your post you actually seem to be completely lacking in how to properly ask for help, as I said even as a 55 year old you probably have an enter key on your keyboard. Use it twice to identify paragraphs, This might seem like a really obnoxious reply, but us who care to read and answer, expect you to actually look at what you posted, and why you think anyone would spend more than two seconds to digest and reply a completely turgid and un formatted question will probably not be answered very quickly.

Apart from that, what are you asking?

Hey…I put my first Asterisk system in at 57!


And I, damn I can’t remember, it must be that CRS syndrome I suffer from, but my son says I am older than shit and he has an ipad so he must be right :wink:

Hey Tadpole, why do you have to be so hateful? This is the second time you have slammed me. I have been nice to you and just asking for some help. I am sorry that pisses you off, but please keep it to yourself.
I really had hoped that I was going to get some help, not slammed. I was trying to tell you that I was unsure of what you was wanting, but still telling what I knew which was vary little. Maybe I am a little wordy, but there is no reason to treat someone like that.
I showed you the link that I found and followed.
I am getting the sip to connect, but I can not get the extensions to register. But this is the samething I have said both times.
But the last time, I just tried to explain what I have done.
So if you do not want to assist me, that is fine, but please dont be so hateful about it. This world has enough problem right now and people need to try to get along.

I still will thank you for taking the time to respond. I am hoping for some help.

Since I was new to all of this, I was just trying to tell a little bit about myself. I didnt mean to upset anyone. I just hoped I could make some friends, that would understand where I was coming from, that this is all new to me. That is great that you are 57, so I would hope that you would know where I am going through.
I am using FreePBX Distro, the latest version.
I have read plenty, but cant seem to find why my extensions are not registering. The panel shows that I am connected to the SIP. It seems like I am getting real close, just if I could get past this part. I have read many of different ways and nothing has worked.
I am running this on its own server, with nothing else. I though maybe someone had the same problem when they started up with Vonage and Grandstream, they would be able to tell me what they did to get them to register.
I am just asking for some suggestions to try.
Thank you too for your fast reply.

There is no hate from me just a request that you separate your thoughts with paragraphs, I guess that went right on by you as you still have not found where your return key is, oh well.

Again try to:-

Ask a question while supplying details as to what you have tried to resolve the problem.

then maybe

Ask another one, while still supplying details as to what you have tried to resolve the problem.

It is just simple etiquette. This way we can try to read through your muddle-headedness.

Many (myself included) will just not read dense overrun badly constructed messages. Your choice, maybe someone else will spend time decoding your requests for help, maybe you can also try to clarify.

Do you see how layout might help your cause?

To correct you also, I slammed you once, not twice, apparently to no avail. I NOW have slammed you twice :wink:

Also just to elucidate there are many tadpoles on this site, I am dicko truly a tadpole, but so are you a tadpole, would you like me to call you tadpole while you said your name was danielbo or would you tnink of that as someone who was not familiar with this site. ?

I am sorry my grammar is not up to your par.

I have asked the question: I can not get my extensions to register, they are Grandstream IP phones. The SIP is registered.

I am sorry that you did not take time to read, but I supplied the link to what I had done, but here it is again. I went step by step.

I as mentioned, with out spaces, but with new paragraphs. I am using the latest download of FreeBPX Distro.

This is on it own server with nothing else on it but the program.

I am not here to fight, I do not believe in it, nor do I believe in being hateful to people that are asking for help. I try to help when I can.

I do hope this helps you understand what I am asking. I do want to send my apologizes, That was not you that I had a reply back before asking what I was using.

Thank you in advance for any assistance you might be able to give me.

If I am able to give you any more information, please just ask. As I mentioned, I am just learning it.

Thank you, I must have not seen your reply. I am sorry about that.

I believe I have a basic in provisioning the phones, I had them working in 3CX. But now I am unable to get them to register.

I followed the getting started guide lines, and have been able to got my SIP on line with no problem. I did a search on "getting grandstream phones provisioned with FreePBX. I found some links and followed each one of them, even on different phones.

My network goes into a linksys gig router. I have not changed anything since I have started trying to use this program on the network. I am using a server with just Free PBX Distro on it.

I had read about a few other PBX setups, and this Distro seemed to me the one I needed to start out with, to learn about the system.

I have also from the program downloaded the provisions for the phones, hoping that would help. I am just stuck right now getting the extensions to register. I have reviewed my setup over and over again and do not see anything wrong. I am sure it it just one little thing.

I am hoping that someone might have had this same problem and would have a answer, or something for me to try. Maybe there is something else I should have set up besides the SIP, and of course the extensions. This is really all I have done so far. Might been a few other little things the set up had me do.

Thank you for any help.

DAnielbo, even with all that typing you still have not asked a question other than a plea for help.

I don’t thing anyone cares about your education but for someone who points out they went to collage (Sic) you spelling, grammar and sentence construction are painful at best to read.

i still have no idea what you have done. did you create two extensions? did you put the extension number, sip secret (password) and ip of the server in the telephone? That’s all it takes.

Can you ping the phone from the server?

I would not try the endpoint manager now, it requires knowledge of dhcp and tftp that II doubt you possess.

All of these steps are covered in the numerous getting started guides for freepbx. all the flavors are basically the same.

sorry for capatilzation errors, my droid for keyboard is acting wonky

I have no idea what you are talking about. Maybe you can not read? If you can not help, just do not bother to respond. I wish the world would be as perfect as you are, and all would be grand.

I have said many and many and many of times that I CAN TO GET MY EXTENSIONS TO REGISTER, THE IP IS CONNECTED.

I also sent you a link to what I have done, plus many more.

I was not bragging about my college, I was just trying to introduce myself. I would like to know a little about whom I a chatting with, but with you I have found out enough. You are just some one who enjoys, trying to cut people down. Well you didnt me, it just showed how big of a jerk you are.

I can ping from my server, and have done so. I have also followed all the steps. I am looking for someone that has had this problem and suggestions. Evidently you have not had this problem, because you are so perfect.

I have said that I have set up all my extensions, and tried what I read on each of them.

So if you are not willing to help with out being hateful, please don’t. I will wait for someone that will.

I am unsure on what or why you are so hateful, but you need to get it checked out. No one I have ever chatted with have been like you.

I just asked a simple question, and you were unable to give a simple answer or help. I CAN NOT GET THE EXTENSIONS TO REGISTER. I feel bad that I am acting like you and I will say that I am sorry! I do not like to be hateful to anyone.

Now I understand, that you can’t get your extensions to register, then please read the “Documentation” link as I said on the right and the bottom of this page, it works for EVERYONE else. That you think I am “hateful” is your problem. maybe your inattention to detail as you have so previously demonstrated is a continuing problem for you maybe it is because you are 55 and have lost your brain, just keep on following those guidelines rigourously and believe me it will work for you as it works for everyone else unless you are the sole special case out there.

Easy rules

Make an extension in FreePBX and assign a password.

use the same extension and password on your phone to match, and point it at your server it really can’t be more simple than that.

If your phone is not on your local network and you are not publically available read how NAT works, and so provision it. No-one can say it more simply than that. It is YOUR problem to allow SIP and RTP sessions through EVERY firewall/router you have in your system. That is all and each and everyone of those points are covered in the Documentation.

p.s. It is not hate it is just exasperation, I have little time for someone who doesn’t at least try. and relies on whining. Generally neither will work here.

I am sorry for some of the things that I had said, I was just thinking the comments was coming from the same person. (tadpole) But the remark on the college was not necessary either. Maybe this is not for me. I have reached out for help and all I got was nasty slams. I do like to know whom I am talking with, and I was just trying to tell a little about myself. Nothing big.

Maybe I am use to people on Homeseer community board, we all are friends. We know what each other do and when someone needs any type of help, some one reaches out and gives it. Not matter what it involves.

I did notice that my reply back to you that stated what was going on was clear back to the top of the page. That maybe you did not see.

But the issue is that I can get connected to the ip, but I can not seem to get my phones to register. I can connect to the phones by putting in the addresses, so I know they are connected to the network. I do get a flashing icon in the upper right hand corner of the phone, where that will go off if I unplug it from the net work. So that would lead me to believe that I am getting close to resolving it.

Since I do not know you, I dont know how much you know about the program that I am using. I am using Free PBX distro. Should I try something else? From what I had read was that it was the easiest to set up.

I have goggled “registering grandsteam ip phones to Free PBX Distro” and did come up with other that had the same problem, but no one seem to get it an answer. I did get some links to some sites that gave me some things to do, and I did them to all 10 phones that I have hooked up. At one time I did have one phone show up registered. Checked other compared to it, and all was the same, but now again none of them are registered.

I just need to find a way, or what my problem is that the phones will not register, I had even in the program down loaded the provision for the grandstream phones.

You mentioned not to try the endpoint manager, which I am unsure that I am doing that. I am just working on the part where it says extensions on the menu, plus I have been working on the provisions on the phones. I think the secret message was one of my problems, but I have made those all the same. I found that out from one of the articles off google.

Thank you for any help, and I am sorry for being hateful.

Thank you for your help and I will try, but I believe I have done this. I have been working on this for over a week now. Not once have I whined, I just asked if anyone has had this problem and might have an answer, after I had done intensive research.
Thank you.

I did this to all of the extensions to make sure it was not the phone, or the network. but I was sure it wasnt the network since I can communicate to the extension by ip address. Still I am getting not registered on the phones.

I am now trying to reboot everything one more time. If this doent work, then I am going to try just FreePBX, not the distro version.

If that doent work, back to 3cx. I like these versions since the have the intercom feature, were as 3cx does not.

Would you have any other suggestions on a program that I might try?

I can assure you that most people have no problem after following the guidelines and their Grandstreams register without problem. there can thus be only one difference, and that is you, you are doing something wrong.

Sorry for the hard words but until you understand what you are doing you will continue to stumble in the dark, your phones register to Asterisk not FreePBX, that is just a front end to help you so let them register.

Again and without prejudice just please try reading all you can and try to understand , it really works for everyone else, whether they use FreePBX and Asterisk from Schmooze or PIAF or . . . .

Anyway please go in peace, I can no longer even try to help you.

Thank you for you help, I do want to let you know that I have read plenty of instructions on how to program, and even found another one today. I will agree with you there is just one little thing that I am sure that is holding me back.

I am trying another PBX program in hopes that maybe I can get this one to work. I was curious on which one that you use and what types of phones?

I did mention that I did find where there was some others with the same problem, but they did not get any help.

I used 3cx and had no problems in programming, just the intercom feature. This is the only reason I am trying other programs.

This has not been a over night project, I have been working on it now over two weeks and done a lot of studying. This is why I was picking your brain for maybe suggestions on the best program to use.

I remain confused when you talk of “programs” if you talk of “FreePBX based distributions” the underlying code is exactly the same. But there is also Kamailio FreeSwitch SIPexec yate and other open source voip servers, I suspect that you will be more comfortable with FreePBX/Asterisk.

Asterisk is a software PBX and a Back to Back User Agent VOIP wise, FreePBX is a php/html/mysql based front end to Asterisk, there are versions of both that go back years but the concept remains the same with any “program” you will “find”. Try to think of it as suite of programs that all coexist and provide different function, that is why it so importatnt that you understand what you are trying to do.

Personally I build my own servers on top of Debian, add Asterisk, php,apache2,mysql and ultimately FreePBX for the PBX front ends plus iaxmodem, t38modem and hylafax for FOIP

Any and all Sip compliant phones will work against it and the endpoint management is FreePBX for most but Aastra’s XML scripts for Aastra, I am not a fan of Grandstream as I consider them clunky and poorly made with bad acoustics and feel, but that is just my opinion, they work just fine as do Snom, Mitel, Cisco the list goes on.

But for you, I suggest that Schmooze and PIAF are generally considered the best prepackaged distibutions out there, any of the other surviving distro’s are known to be incomplete old or just plain bad.

I can’t remember a SIP based phone that coudn’t at least register with those three settings I mentioned, extension, password and server, provided you have your network correctly configured.