New to PBX, Cannot get IP

Hello, First off, I’d like to say that I am knew to using PBX.
Anyway, my manager has me making us a PBX phone system for both our stores. We made one for our current store, And it’s working fine. We are making one for our second store at the moment, but I hit a major snag. it quit making an IP address. I cannot log into the GUI since it does not have an address, Does anyone have any suggestions or advice for me? Please and Thank you.

P.S. This PBX system is made form a Dell Desktop

you have to use ssh or root access to access the pbx and check by linux command.

I am in the commands, but I cannot seem to figure it how to set this.

what does command ifconfig show?

There is never a good reason to rely on DHCP to assign your ip on a server of any kind. Ask whoever manages your DHCP server to statically assign a working to your mac address. If he doesn’t provide an DHCP server, then hard code an IP address , netmask and gateway in your network interface files that does not collide with any other host and is in the network of the interface you are using. Even if he does, please make that network presence static anyway

I’m sorry I forgot to mention that part. I set it up for a Static IP. Everything worked fine until last week sometime. I turned it off to make room for other stuff to work on. Since it is for our other store, We didn’t need it running. I turned it back on, no IP

Please explain further, you set up a static ip but it doesn’t have it as set the way you did it ?

I would suggest you might have not done it right. So “ip addr” from bash will give you your next step.

(ip is far more able than ipconfig if you choose to use it)

thank you, I am still kinda new. I tried ip addr, I don’t see anything I know as useful.

Nor do I , you didn’t share it :slight_smile:

Im with @dicko. I always assign a static somewhere high enough in the scope that it wont hinder anything else.


It was set to a static IP address on a network with nothing else in that range.

Okay, So Someone on Reddit thankfully gave me the console commands to change the IP. Problem solved now :slight_smile:
Except now it thinks the system isn’t activated, and the activate button does nothing. :confused:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.